Cuppa Herbiboar 1.2.10

Want the Herbi pet? Of course you do.

  1. CuppaJava
    Hunts herbiboars. Supports banking at Castle Wars or Fossil Island. Also supports stamina and energy pots.


    Usage:
    • start the bot near the Mushroom Forest on Fossil Island
    • have magical secateurs equipped (optional)
    • recommended: have auto retaliate off and left-click-attack NPCs off
    • optional: have stamina/energy potions in the bank
    • optional: if banking at castle wars, have a digsite pendant & ring of dueling equipped, and plenty in the bank
    If banking at Fossil Island, ensure the bank chest is built. If banking at castle wars, ensure digsite pendant Fossil Island teleport & mushroom network teleports are unlcoked.

    Features:
    • Efficiently hunts down herbiboars, with plenty of failsafes
    • Can bank at Fossil Island bank or Castle Wars
    • Optional Stamina/Energy pot support
    • The bot is careful around the Level-109 Ancient Zygomites. If one ever targets the player, the player will run away. Also clicks more precisely near them to avoid them.
    Features in all of CuppaJava's Bots:
    • Saves settings from last session, even when you close Runemate. Jump right back in next time!
    • Customizable break handler, to log out for a little while every X minutes.
    • Customizable AFK handler, to idle the bot for a little while periodically.
    • Customizable stopping handler: to stop the bot after a selected amount of time.
    • Intelligent delays between actions.
    • Progress log with a bunch of info.
    • My own custom, robust traversal system written from the ground up. Doesn't rely on the Runemate "web" to work!


    [​IMG]



    [​IMG]
    [​IMG]

Recent Reviews

  1. FranchescaNear
    FranchescaNear
    5/5,
    Version: 1.2.5
    Literally 48 hours from 80-90 hunter, 2 Sessions of 24 Hours, 15 days ago and no ban, i'de rather this bot is Excellent

    My Setup :
    Time Between Breaks : 70 Mins
    Break Lenght : 20-30 Mins
    Uncheck Herb Sack
    Random AFK Handler Enable
    1. CuppaJava
  2. Hamon1994
    Hamon1994
    4/5,
    Version: 1.2.5
    Worked great for one hour but is now stuck at the big yellow mushrom trying to inspect the smelly mushrom ovr and over again...
  3. virtuehf
    virtuehf
    5/5,
    Version: 1.2.5
    Is there anything this guy can't do? Runs smooth like all his others.
    1. CuppaJava
  4. ArrancaRabo
    ArrancaRabo
    5/5,
    Version: 1.2.2
    Another excellent bot from Cuppa, just sit back, put screen on full zoom out and facing north and watch the magic happen with a cuppa tea.
    1. CuppaJava
  5. Eiwittenhoog
    Eiwittenhoog
    1/5,
    Version: 1.2.1
    Tried for the first time today, got stuck without catching a herbiboar. Keeps clicking in between 2 objects even when the path is already revealed, when it gets stuck like 10 times it proceeds to hop worlds then does exactly the same thing again. Maybe it has something to do with the start position of the track? The one at the farming patches just always seems to get stuck.
    1. CuppaJava
      Author's Response
      It's possible this is a bug in the bot, but just to cover all the bases, could you please try clearing your OSRS game cache then restart both runemate and osrs. And make sure to not switch screen mode (resizable/fixed) while runemate is open.

      Let me know if this fixes it, people often seem to have caching issues after game updates.
  6. PrimeauS
    PrimeauS
    3/5,
    Version: 1.1.3
    It was working great, but now there is currently an issue with the failsafe where it seems to not be able to find my magic secateurs even though they are equipped.
    As a result, it just isn't working anymore.
    1. CuppaJava
      Author's Response
      Please try clearing your OSRS game cache then restart both runemate and osrs. And make sure to not switch screen mode (resizable/fixed) while runemate is open.

      Any time the bot can't find an item, it's almost always related to this. It's a runemate client bug.
  7. Aussie_nomad
    Aussie_nomad
    5/5,
    Version: 1.0.33
    just cleared my cache and worked great over night got me 450kc no issues
  8. Boo_
    Boo_
    5/5,
    Version: 1.0.30
    Great bot, was working great for the last week, today for some reason it said Failsafe activated cannot find magic secateurs when they are already equipped. Tried starting with them in inventory still continues to kick me off, I have been charged each time, please refund me for the last few times it went off. Hope to hear from you.
    1. CuppaJava
      Author's Response
      Hello, I've replied to your PM :)

      If anyone else reading this is having the same issue, the advice I gave was basically to clear the OSRS game cache (usually fixes this type of stuff) and test using the lite version (as it gives you a free hour per week, useful for testing when the bot crashes).
  9. DeadlyMeowster
    DeadlyMeowster
    3/5,
    Version: 1.0.29
    the amount of times the failsafe goes off in an hour is retarded. I'm sorry but why cant your bot move the camera to follow the tracks? Instead it gets stuck and constantly hops.
    1. CuppaJava
      Author's Response
      The failsafe has nothing to do with the camera not being able to see the tracks. The failsafe executes when it encounters a (supposedly) rare bug and gets confused/not sure which trail is the new one. In my testing I've only ever seen it execute a handful of times, and you're the first person to say it happens often.

      Judging by your extremely negative reviews on multiple authors bots, I'm under the impression that the issue is on your end/you're experiencing client bugs that are making things break more often.

      I'd recommend clearing your OSRS game cache and restart both runemate and osrs. As well, make sure to not change screen modes (resized -> fixed or vice versa) while runemate is open as that can cause bugs.
  10. JKunch
    JKunch
    4/5,
    Version: 1.0.24
    So I'm not sure if I'm doing something wrong here, but the bot has a few issues that I have found. I ran it for about 4 hours on and off after the problems. It seems to get stuck sometimes on this certain trail. It just stands there and says interacting with target but never moves unless you move the character. I have had many log outs with the fail safe feature (which is really nice and appreciated). It seems to get lost or cant click what it needs too. If I'm doing something wrong and no one has these issues than 5 stars hands down it really is a well written script. Just letting people know what's going on.
    1. CuppaJava
      Author's Response
      I'd be a bit surprised if the bot was missing a trail at this point to be honest, as no one else has mentioned it. But all the trails were added manually by me and it is possible I missed one.

      If this happens again, would you be able to PM me a screenshot of:
      1) the object inspected (mushroom, seaweed, dirt patch, etc),
      2) the beginning of the path generated (the first step in the trail)
      3) where the trails leads to (the next thing to inpect)

      That way I can match them up to my own game and add the trail coordinates if it's missing, or double check that it's there :)