Resolved Bot doesn't run to specific Area

Discussion in 'Client & Site Support' started by NastyNate, Jun 6, 2015.

  1. Since the new update the Bot doesn't run to the specific Area that I designated. I've also noticed when using the developer tool "Area Maker" It normally draws to minimap. I can no longer see that aswell.


    EDIT: Running on Fixed Mode.

    @Cloud

     
    #1 NastyNate, Jun 6, 2015
    Last edited: Jun 6, 2015
  2. Best Answer:
    Post #7 by g4802011, Jun 7, 2015
  3. Where abouts is the area and which Path type are you building/using?
     
  4. So it's not just me? Trying to write my first script bot here, but it just won't move when told to.

    public static Area bankArea = new Area.Polygonal(
    new Coordinate(2331, 3691, 0),
    new Coordinate(2331, 3687, 0),
    new Coordinate(2328, 3687, 0),
    new Coordinate(2328, 3691, 0)​
    );​

    Path p = BresenhamPath.buildTo(bankArea);
    if(p != null) {
    System.out.println("Step");
    p.step();​
    }​

    I do get spam "Step" in console, but nothing is happening.

    Also tried this:

    WebPath toBank = Traversal.getDefaultWeb().getPathBuilder().buildTo(bankArea);
    if (toBank != null) {
    System.out.println("Step");
    toBank.step(true);​
    }​

    Again, it spams "Step" but nothing happens.

    It's OSRS, fixed mode
     
  5. Circular I even tried Rectangular and that didn't work. I was using RegionPath but also Tried BresenhamPath and that didn't work.
     
  6. which area maker were you using
     
  7. Area Maker by @Viewer
     
    #6 NastyNate, Jun 6, 2015
    Last edited: Jun 6, 2015
  8. This got fixed with the update yesterday.
     

Share This Page

Loading...