Resolved Bots aren't running

Discussion in 'Client & Site Support' started by Krosden, Sep 25, 2015.

  1. As of today I can't get most bots to run. Last night everything was fine.

    I've reinstalled my Java versions, cleared my Java cache and log files. Still nothing.

    MaxiWorldWalker still works though, I just can't woodcut or do agility or anything else :l
    Running Windows 10 on a desktop. Tonight I'll be testing the bots on my Windows 7 laptop. I've seen on the forums that this issue has apparently been fixed, but I'm getting it over and over all of today.
  2. What is your gamepack ID? It should show up right before the game finishes loading. @Cloud check logs please. We don't want to get in the way of Double XP botting. ;)
    Microsoft likes this.
  3. Gamepack ID: 9043232c

    Was busy tonight, and I'll test my Windows 7 tomorrow :)
    --- Double Post Merged, Sep 26, 2015, Original Post Date: Sep 25, 2015 ---
    I should mention this is OSRS
    --- Double Post Merged, Sep 26, 2015 ---
    Windows 7 has worked perfectly fine the whole night. Currently still in bed using remote desktop on my phone so I'll try using the bot on my desktop again later.
    --- Double Post Merged, Sep 27, 2015 ---
    Tested again and doesn't work on Windows 10
  4. This isn't an issue related to Windows 10.
    Uninstall all your Java including file/registry leftovers, and install the latest one.
    [I'm on Windows 10, and I'm having no problems whatsoever]
  5. I had no problems up until a couple of days ago either, worked perfectly fine. As previously said, I've reinstalled my x86 Java, and cleared the cache and log files, do you recommend just uninstalling everything Java and starting over?
  6. Yes, but make sure you uninstall it fully
    Krosden likes this.
  7. I uninstalled Java 32-bit and 64-bit, and used CCleaner to wipe any registry relating to Java. I still can't run any bots. (After reinstalling Java)
  8. Try cleaning your temp folder.
    Add me on Skype to discuss about it. [djskywalker5]
    I will post the solution for others once found :D
  9. i got java problems aswell
  10. - Cleared RuneMate from my %userprofile% folder
    - Cleared my full %temp% folder
    - Cleared all Java Trace and Log Files, Cached Applications and Applets and 'Installed Applications and Applets'
    - Ran both CCleaner and IOBit Uninstaller to completely uninstall Java (Along with standard Windows uninstalling in the control panel)
    - Recently installed AVG around the time of this bug occuring, used both AVG uninstall and IOBit Uninstaller
    - Rebooted the computer multiple times and used 'Microsoft's' problem solver over at

    Still no resolution.
    #10 Krosden, Sep 27, 2015
    Last edited: Sep 28, 2015
  11. @Cloud please check this gamepack. I have a hunch there's something wrong with it.
  12. T'is what my game shows (see screenshot)

    I can check to see if my laptop has the same ID later today. (Yes, it does. As I expected)
    --- Double Post Merged, Sep 28, 2015, Original Post Date: Sep 27, 2015 ---
    I took note of my CPU and RAM usage running a bot and letting it idle. My usages do go up as if the computer is running the bot, when I stop a script bot the usages then go back down to normal.

    Attached Files:

    #12 Krosden, Sep 28, 2015
    Last edited: Sep 28, 2015
  13. Did some more testing.

    MaxiWorldWalker works.
    MassFighter works.
    Pick 'n Bury and ExpertBones work.
  14. Can't be gamepack, OSRS only has one gamepack.
  15. Still trying everything, while having RuneMate open the Java platform running was javaw.exe (Just a version of Java that hides the console)
    I set javaw.exe to run as administrator, after testing that out I then set it to run in compatibility mode for Windows 7 (Even though I'm on Windows 10).

    Still nothing. I tested running Celestial Hunter and the bot after 3 - 4 minutes would put down a bird snare, then freeze and do nothing like most bots I run at the moment.
    --- Double Post Merged, Sep 30, 2015, Original Post Date: Sep 30, 2015 ---
    I've also run a few fixes on Microsofts problem solver they've posted to see whether or not it was a slow mouse issue etc.
  16. Are you running a 32bit operating system by any chance?
  17. Could this be related to the "Hidden title bars" thread that was made? After skimming this thread as well, I would say I sort of have this problem as well. Everything ran fine but trying to bot on RS3 is not working. The bots "run" but do not take control of the mouse to do any actions. The bots I have tried have sat there idle. I will post a video in a few minutes. My gamepack is 40ff7bc2.

    Video of divination bot.
    #18 ttyler333, Sep 30, 2015
    Last edited: Sep 30, 2015
  18. Nope, 64bit operating system, Windows 10. My laptop which runs everything fine is 32bit Java on a 32bit operating system, no problems. My desktop I've had both 32bit and 64bit installed separately as well as installing them together (Which they have been for the last few months anyway). With 32bit Java, RuneMate gives the usual 'Use 64bit message'.
    User system settings; System type: 64-bit Operating System, x64-based processor

    Watching your video I seem to get the same thing happening (For nearly every bot I have), although I am using OSRS. I also don't get your "Hidden title bars" error. My bot will just run, but not 'do' anything.
  19. Someone else was getting the hidden title bars and the bot not running.
    Yeah I am on rs3 and in legacy mode where the setting for the hidden title bars is not accessible. Every bot I have does the same thing; I figured the divination bot was easiest to show off :).

    Is runemate even looking into this issue? @Cloud
    #20 ttyler333, Oct 1, 2015
    Last edited: Oct 1, 2015

Share This Page