Resolved bots not longer working on Mac

Discussion in 'Client & Site Support' started by mabinogi, Apr 12, 2015.

  1. mabinogi

    Joined:
    Mar 16, 2015
    Messages:
    71
    Likes Received:
    6
    Someone is also experiencing this?

    Running RM on java jdk 8u40, OS Maveriks, running fine until 4-5 hours ago. When I click on a bot and the GUI comes up, then I click on start and the client freezes. Running thought sudo command. Not showing any error or console nor runemate error popup. Working fine on windows.

    Removed all runemate files same as rs files and redownloaded runescape . This does not fix the problem.

    @Cloud

    thank you.
     
  2. Arbiter

    Arbiter Mod Automation

    Joined:
    Jul 26, 2013
    Messages:
    2,557
    Likes Received:
    1,072
    There was a new update in the last 4-5 hours ago, but I don't think anything we did should've affected OS compatibility. Deferring to @Cloud on this.
     
  3. mabinogi

    Joined:
    Mar 16, 2015
    Messages:
    71
    Likes Received:
    6
    Ok thank you arbi.
     
  4. EvilCabbage

    Joined:
    Nov 3, 2013
    Messages:
    2,114
    Likes Received:
    696
    The bot also crashes on mine and @emily s Macs when you try to turn off a bot. Starting one up works like it should but when you turn off a bot you get the rainbow wheel (which means a program stopped responding)

    EDIT: This crashing when turning off the bot only occurs when using OSRS and only started recently. It doesn't always happen but only sometimes.
     
    #4 EvilCabbage, Apr 12, 2015
    Last edited: Apr 12, 2015
  5. mabinogi

    Joined:
    Mar 16, 2015
    Messages:
    71
    Likes Received:
    6
    i get that rainbow when I close the client itself, but never with scripts bots XD. but that also happens with bots like maxithiever etc.
    --- Double Post Merged, Apr 13, 2015, Original Post Date: Apr 12, 2015 ---
    after client loads

    (10:24:29) [Setup] Syncing with RuneMate Cloud (******)...

    (10:24:53) amz: java.lang.reflect.InvocationTargetException

    (10:24:53) at sv.k(sv.java:132)

    (10:24:53) at sv.v(sv.java:101)

    (10:24:53) at adv.<init>(adv.java:250)

    (10:24:53) at cr.v(cr.java:14)

    (10:24:53) at dz.o(dz.java:66)

    (10:24:53) at aee.v(aee.java:60)

    (10:24:53) at aig.fp(aig.java:2058)

    (10:24:53) at fa.fy(fa.java:2011)

    (10:24:53) at np.gu(np.java:2194)

    (10:24:53) at aay.c(aay.java:157)

    (10:24:53) at tn.g(tn.java:74)

    (10:24:53) at ahn.ato(ahn.java:12586)

    (10:24:53) at mw.y(mw.java:993)

    (10:24:53) at cj.r(cj.java:371)

    (10:24:53) at io.l(io.java:264)

    (10:24:53) at gw.g(gw.java:202)

    (10:24:53) at client.gz(client.java:2789)

    (10:24:53) at client.aa(client.java:1524)

    (10:24:53) at rp.j(rp.java:569)

    (10:24:53) at rp.s(rp.java:545)

    (10:24:53) at rp.run(rp.java:502)

    (10:24:53) at java.lang.Thread.run(Thread.java:745)

    (10:24:53) Caused by: java.lang.reflect.InvocationTargetException

    (10:24:53) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    (10:24:53) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)

    (10:24:53) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

    (10:24:53) at java.lang.reflect.Method.invoke(Method.java:497)

    (10:24:53) at sv.k(sv.java:123)

    (10:24:53) ... 21 more

    (10:24:53) Caused by: java.lang.SecurityException

    (10:24:53) at app.dK.checkLink(xkb:146)

    (10:24:53) at java.lang.Runtime.load0(Runtime.java:803)

    (10:24:53) ... 26 more
     
  6. Arbiter

    Arbiter Mod Automation

    Joined:
    Jul 26, 2013
    Messages:
    2,557
    Likes Received:
    1,072
    Tagging @Cloud again because the exception is very helpful.
     
  7. Cloud

    Joined:
    Jul 28, 2013
    Messages:
    2,557
    Likes Received:
    922
    That exception isn't an issue, we simply blocked the OpenGL library from loading on OSX. I can't think of anything that we changed that would result in an issue like this. If I uncover anything I'll let you know.
     
  8. mabinogi

    Joined:
    Mar 16, 2015
    Messages:
    71
    Likes Received:
    6
    well, the only bots that are not working are celestials ones except celestial bank wealth calculator. maybe is because these bots use that library?

    thank you.
     
  9. Infinite Inferno

    Infinite Inferno The Pip Collector

    Joined:
    Sep 14, 2014
    Messages:
    435
    Likes Received:
    120
    We don't use the OpenGL library loooool.
     
  10. mabinogi

    Joined:
    Mar 16, 2015
    Messages:
    71
    Likes Received:
    6
    then something changed yesterday afternoon at rune mate client...
     

Share This Page

Loading...