Resolved Can't start RuneMate.jar

Discussion in 'Client & Site Support' started by Boneka, Sep 13, 2015.

  1. Hi all,

    I've been using RuneMate for quite some time now and I never had any problems with it until recently. I'm one of the stupidest people when it comes to computers, besides playing a game, so I try to seek help out here.

    So what happens is when I try to start the RuneMate.jar file nothing happens. I can click on it as many times as I want but nothing happens while the login screen for RuneMate should appear. What does happen is that Java(TM) Platform SE binary does open in the background processes just as many times as i tried to start it.

    So the things I tried myself to solve this issue is adjusting firewall settings, adjusting Java settings (which turned out to be only for the browser lol), trying to open it through command prompt and reinstalling Java's latest version. None of them solved the problem for me.

    When reinstalling Java it would be possible to open RuneMate.jar again and use the bot. The only problem is that the next day everything is just the way it was before. Same for the verification of Java through the browser. When RuneMate is working it will verify and when it doesn't it cannot detect Java. That's why I'm pretty sure that it's probably something on my laptop what causes it or maybe it's a problem with Java, which is unlikely cause so far I know I'm the only one with this problem.

    I hope someone knows how to solve this problem. I hardly have any knowledge about computers, programs etc. I've tried my best so far with the help of google and browsing this forum but it didn't help out.
  2. It sounds very much like you have an infection on your computer. Please do a full scan with an anti-virus like Malwarebytes (free). Hopefully that will resolve your problems. If not, the next thing I would suggest is a full re-install of your operating system. With Windows 10 recently out it's as good a time as any. If that is not an option you're going to likely need to seek professional help as this kind of thing gets pretty time consuming even for an expert.
  3. Thanks for the reply. I have norton antivirus and I did a full scan already. Nothing was found. Besides that, my laptop works just fine. It's not slow or anything and everything works as it should, except for Java. I will do an other scan just to make sure. I'd rather not change the operating system unless it's really needed. If nothing comes out of the scan I will try to reinstall Java again and if the same thing happens I should really start thinking about taking it to an expert.
  4. @Cloud I am having this same problem actually...the only way I can get runemate to launch is by making a dummy project with no program arguments in intelliJ, and then running that.
  5. Nothing was found with the virusscanner. I've found out something else though. When I open my task manager and go to the tab details I see several Java.exe processes running. I cannot kill them cause it says acces denied. When I go to the process tab I cannot see any Java running. Whenever I try to start RuneMate I can see Java(TM) Platform SE binary running as a background process and an other Java.exe gets added to the tab details. I think I must have over 20 of those at the moment and there is no way to get rid of them. All of them say access denied and they won't go away even after I restarted my laptop.

    Does anyone knows what this is? This might be the problem for me. And if anyone knows how to solve it that would be great :D
    --- Double Post Merged, Sep 13, 2015, Original Post Date: Sep 13, 2015 ---
    I just tried to uninstall Java but when I try to do that it tells me to close some things first. It shows me a list which only consists of Javaw.exe times 20 or so.
  6. Have you restarted your PC and then tried uninstalling?
  7. I'm running some other stuff now. I will try it later this evening and update this thread about how it went. I tried restarting my laptop before to get rid of the Javaw.exe but it didn't help so I think this won't do much either. But I will try anyway.
    --- Double Post Merged, Sep 13, 2015, Original Post Date: Sep 13, 2015 ---
    Even after restarting my laptop I cannot uninstall it. It keeps saying I need to close Javaw.exe. I think the problem is either Java or my laptop.
  8. I doubt it's Java unfortunately. It's only used in 8 billion+ computers. :p
  9. Hmm I think so. The thing is that RuneMate would keep running and not respond only when I used Z0na's motherload on rs07. Maybe it has something to do with it cause after that happened I needed to restart my laptop to be able to do anything myself again cause otherwise it would just not respond. It's also the last script bot I've used.

    I think I can solve the problem as long as I can kill the Javaw.exe processes. I tried to kill them through commandprompt with the 'taskkill /F /PID *PID no.*' command but it says access denied. I can't seem to figure out how to get the access to kill the Javaw.exe. I hope once I can do that I can solve the problem.
  10. @Cloud penny for your thoughts.

    Sent from my iPhone using Tapatalk
  11. Somehow I was able to uninstall Java. I reinstalled it and now it seems to be working for the time being. Can this thread stay open just to be sure? Cause last time this happened it worked for a day.

    Thanks for all the help :D
    --- Double Post Merged, Sep 17, 2015, Original Post Date: Sep 14, 2015 ---
    It is still working for me. I guess this thread can be named solved now although I don't know how. I don't know how but suddenly I was able to remove Java and reinstall it. Ever since then it's been working great. I honestly think there might be a connection between the Z0na motherload bot and the crashing of RuneMate, at least for me. When I had Z0na motherload mining on and my laptop would go on stand-by, nothing would respond anymore on RuneMate while it kept mining. For me to be able to do anything again I had to restart my laptop cause after I turned off RuneMate it wouldn't start again. That's why I think there might be a connection.
  12. Did you try running cmd as an administrator?
    --- Double Post Merged, Sep 17, 2015, Original Post Date: Sep 17, 2015 ---
    Try running the bot again to confirm your suspicions? And if that's the case, you should post on the bots thread. I'll mark this as resolved. If it starts happening again when you run bots other than Z0na motherload miner just post here and tage one of the staff and we'll change it back to being unresolved :)
    Boneka likes this.
  13. I need help too start it!
  14. You should uninstall all Java software from your pc.
    Reinstall the latest one, and if that didnt help also run a program [as admin] called Jarfix.
    --- Double Post Merged, Sep 19, 2015, Original Post Date: Sep 17, 2015 ---
    Since your problem is resolved, please post a reply stating what fixed it ;)
    Will be really helpfull for others ;)
    #14 Microsoft, Sep 19, 2015
    Last edited: Sep 20, 2015
    Arbiter and Boneka like this.

Share This Page