Resolved client not detecting

Discussion in 'Client & Site Support' started by oregon67, Feb 5, 2015.

  1. Hi comunity

    im triying to run rune mate on a Mac OS, but the client doesn't detect me, no matters which bot i use. for example if im in the bank, does not detect the banker, even the crafting items i need.
    The client detects the bank pink and correctly introduces it. Even i use autofigther or autocrafter, the bot does not click any item or npc.

    Im using runemate beta 1.0.0

    pd: im using minimum resolution and fixed mode. i have java 8 revision 31.

    thank you!! :D

    #1 oregon67, Feb 5, 2015
    Last edited: Feb 5, 2015
  2. Best Answer:
    Post #11 by Exia, Feb 8, 2015
  3. @Cloud Does runemate support Mac?
  4. bump!
    the client detects where i am, and walks into the bank, but not clicking and the bot says "opening bank" por example.
    even i have the items needed for smithing or whatever on my backpack, the bot does not detect them,
    i also tried legacy mode.
  5. Same thing happening to me oregon, i guess we just have to sit tight, ive already contacted them
  6. Ok cool, lets hope they fix this. By the way some mac users whose are not having these problems?
  7. I need a developer to chime in with some actual debug information.
  8. I can do that, i could use the bot store developer apps for it rigth?
  9. No, someone needs to run RuneMate in SDK mode and see what's wrong/missing in the NPCs and GameObjects dumps.
  10. I got this as soon as it loaded to the login screen:
    Code (Text):
    2. (08:53:20) amq: java.lang.reflect.InvocationTargetException
    3. (08:53:20) at sr.r(
    4. (08:53:20) at sr.m(
    5. (08:53:20) at adj.<init>(
    6. (08:53:20) at cg.m(
    7. (08:53:20) at dk.y(
    8. (08:53:20) at mz.m(
    9. (08:53:20) at
    10. (08:53:20) at dc.ez(
    11. (08:53:20) at
    12. (08:53:20) at ej.k(
    13. (08:53:20) at em.b(
    14. (08:53:20) at
    15. (08:53:20) at rq.g(
    16. (08:53:20) at rq.e(
    17. (08:53:20) at
    18. (08:53:20) at
    19. (08:53:20) Caused by: java.lang.reflect.InvocationTargetException
    20. (08:53:20) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    21. (08:53:20) at sun.reflect.NativeMethodAccessorImpl.invoke(
    22. (08:53:20) at sun.reflect.DelegatingMethodAccessorImpl.invoke(
    23. (08:53:20) at java.lang.reflect.Method.invoke(
    24. (08:53:20) at sr.r(
    25. (08:53:20) ... 15 more
    26. (08:53:20) Caused by: java.lang.SecurityException
    27. (08:53:20) at a.gK.checkLink(vgb:113)
    28. (08:53:20) at java.lang.Runtime.load0(
    29. (08:53:20) ... 20 more
    It seemed like everything in the dev tools was working, though there were a lot of items under the Objects tab labeled null, I'm not sure if that is normal or not.

    I'm running Ray's nature rune crafter and it's running just fine (It's made several full laps already). The only thing to note is that I ran my jar through terminal. maybe try giving it sudo privs.
    oregon67 and Arbiter like this.
  11. Thanks for looking into that @TheBat. @oregon67 can you try his suggestion and run as sudo?
    oregon67 likes this.
  12. Yay! Works perfect with sudo permissions, so topic fixed. Getting those null items too..a bunch of them.
    Issue fixed ,will make an autoexecutable.

    Thank you,specially the bat, arbiter and cloud.
    Exia likes this.
  13. While this is a good temporary fix, we need to investigate why sudo privileges are needed. Probably Jagex related, because they need access to a cache folder. Hopefully @Cloud can investigate for us.
  14. Sorry but im pretty sure I have the same problem and I still don't understand the temporary fix, how to you run Runemate in sudo and what is the process to fix the ids?
  15. Open terminal, cd to the directory where the Runemate jar is then paste sudo java -jar "./Runemate.jar". Finally type in your password and hit enter, the client should open up.
    Arbiter likes this.
  16. Not a computer guy still not really understanding lol sorry
    so first off
    1. open terminal
    2. cd to runemate.jar? clicked on your link but still don't know what to type in to bring up runemate.jar
    3. what exactly do i paste?

    thanks for helping thebat, i appreciate it
  17. 1. open terminal
    2. copy ur rune mate client to "your mac user folder" (inside this one is your documents folder, pictures folder, etc...)
    3. type in terminal: sudo java -jar Runemate.jar
    4. put your mac user password
    5. enjoy this great bot!!!!
  18. not understanding step 2 lol, when i click finder i dont see my user folder i see in this order:
    Application Desktop All my files air drop movies documents downloads music pictures (which is my mac user folder right?)
    but which one do i drag runemate.jar into?

Share This Page