Resolved Client problems with scripts

Discussion in 'Client & Site Support' started by thejaru, Apr 21, 2015.

  1. After last night's Runescape system update i've been getting errors like the following -->

    This one is for celestial corrupted ore smelter
    Code (Text):
    1.  
    2. java.lang.NullPointerException
    3.     at app.fn.catch(rub:140)
    4.     at com.runemate.game.api.hybrid.region.GameObjects.getLoaded(awb:190)
    5.     at com.runemate.game.api.hybrid.region.GameObjects.getLoaded(awb:232)
    6.     at com.runemate.game.api.hybrid.queries.GameObjectQueryBuilder.raw(xvb:146)
    7.     at com.runemate.game.api.hybrid.queries.QueryBuilder.results(hrb:197)
    8.     at productions.celestial.corruptedsmelter.tasks.OpenSmeltingInterface.validate(OpenSmeltingInterface.java:17)
    9.     at com.runemate.game.api.script.framework.task.TaskScript.onLoop(qxb:232)
    10.     at com.runemate.game.api.script.framework.LoopingScript.run(htb:239)
    11.     at com.runemate.game.api.script.framework.AbstractScript.start(jnb:156)
    12.     at app.bj.run(ukb:214)
    This one is for HaxDivination
    Code (Text):
    1.  
    2. java.lang.NullPointerException
    3.  at com.slashnhax.api.LocalPlayer.getAnimationId(LocalPlayer.java:38)
    4.  at com.slashnhax.scripts.taskscripts.haxdivination.task.HarvestWisps.validate(HarvestWisps.java:34)
    5.  at com.slashnhax.framework.taskscript.TaskScript$$Lambda$496/539733923.test(Unknown Source)
    6.  at java.util.stream.ReferencePipeline$2$1.accept(Unknown Source)
    7.  at java.util.Spliterators$ArraySpliterator.tryAdvance(Unknown Source)
    8.  at java.util.stream.ReferencePipeline.forEachWithCancel(Unknown Source)
    9.  at java.util.stream.AbstractPipeline.copyIntoWithCancel(Unknown Source)
    10.  at java.util.stream.AbstractPipeline.copyInto(Unknown Source)
    11.  at java.util.stream.AbstractPipeline.wrapAndCopyInto(Unknown Source)
    12.  at java.util.stream.FindOps$FindOp.evaluateSequential(Unknown Source)
    13.  at java.util.stream.AbstractPipeline.evaluate(Unknown Source)
    14.  at java.util.stream.ReferencePipeline.findFirst(Unknown Source)
    15.  at com.slashnhax.framework.taskscript.TaskScript.executeTask(TaskScript.java:25)
    16.  at com.slashnhax.framework.taskscript.TaskScript.onLoop(TaskScript.java:16)
    17.  at com.runemate.game.api.script.framework.LoopingScript.run(htb:239)
    18.  at com.runemate.game.api.script.framework.AbstractScript.start(jnb:156)
    19.  at app.bj.run(ukb:214)
    20.  
    This one is for Pixie FDK
    Code (Text):
    1.  
    2. java.lang.NullPointerException
    3.  at app.fn.catch(rub:140)
    4.  at com.runemate.game.api.hybrid.region.GameObjects.getLoaded(awb:190)
    5.  at com.runemate.game.api.hybrid.region.GameObjects.getLoaded(awb:158)
    6.  at org.pixie.fdk.tasks.GroupConditions$6.valid(GroupConditions.java:54)
    7.  at org.pixie.api.framework.ThreadDispatcher$3.run(ThreadDispatcher.java:63)
    8.  at org.pixie.api.framework.ThreadDispatcher$1.run(ThreadDispatcher.java:34)
    9.  at com.runemate.game.api.script.framework.core.LoopingThread.run(xwb:2)
    10.  
    I've deleted my Files from C:/Users/Me/RuneMate and i've deleted the RuneMate.jar and then reinstalled it. Nothing seems to work, changed all my resolutions between fixed and resizeable and high and low graphics, I continuously get these errors. Not really sure what to do at this point, I've asked a few bot authors and they aren't really sure what to do either @Cloud hoping you can help me out :p

     
  2. Best Answer:
    Post #7 by thejaru, Apr 24, 2015
  3. What's your gamepack id?
     
  4. 75a2fee6 is my gamepack ID
    --- Double Post Merged, Apr 23, 2015, Original Post Date: Apr 21, 2015 ---
    bump @Cloud hopefully you can get back to me :p
    --- Double Post Merged, Apr 24, 2015 ---
    hoping I can get some help with this :p
     
  5. i decided to test and see if it was my files that are corrupted or something, so I ran the bot on my mac but I get the same error so it isn't my computer or my files :( Just a quick update if that helps in any way. Maybe making a new RuneMate account would solve the problem?

    EDIT: Making a new account doesn't change anything :p
     
  6. Can you try it now?
     
  7. everything seems to be working fine now! thanks @Cloud !!
     

Share This Page

Loading...