Bug Client stuck on spinning-circle start up screen (Linux)

Discussion in 'Client & Site Support' started by zaheerz, May 2, 2016.

  1. Hey guys, was going to give the rune mate spectre client a try on my Unbuntu 14.04 server (Unity GUI) but i am not able to get passed the load up screen. The green dotted circle in the load up screen of the client just keeps spinning. My java is up to date and I have 2Gb of ram, so those shouldn't really be the problem. Also, the logs for the client are saying anything expect the normal start up info. No errors or anything. Any ideas? Should I run a different Server build maybe?Thanks!
  2. Full desktop environment screenshot please.
  3. upload_2016-5-2_0-20-54.png
    --- Double Post Merged, May 2, 2016, Original Post Date: May 2, 2016 ---
  4. That's not Unity. That's GNOME Classic.
  5. Well shit, my bad! Fairly new to VPS, so sorry about the mix up!
    Anyway, I thought by doing
    apt-get install Ubuntu-desktop
    On a digitalocean Ubuntu server gets unity, atleast that's what there forum says. Do you by any chance know I can get unity?
  6. Try running with sudo to make sure it's not a permissions issue.
  7. Are you talking about running runemate with sudo? Because I sudo installed runemate to home/user/desktop and then gave my sudo account permission to use program using the chmod u+x command
  8. Yes that's what I'm talking about.
  9. Gotcha, I went ahead and did that and was able to get past the loading screen, but I when i tried to start the bot after attaching to my RSU client, it did nothing, and then crashed.
    Here's my log.

    [email protected]:~$ sudo /bin/sh "/home/rune/Desktop/runemate/RuneMate"
    [sudo] password for rune:
    [Debug] RuneMate Version: 2.0.12
    [Debug] Java Version: 8u92 x64 (Oracle Corporation)
    [Debug] Operating System: Linux x64
    libGL error: failed to load driver: swrast
    ES2 Prism: Error - reported GLX version = 1.2
    GLX version 1.3 or higher is required
    Scanned for and identified 0 game frames in 1122ms.
    Scanned for and identified 1 game frames in 2459ms.
    java.lang.UnsatisfiedLinkError: no attach in java.library.path
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1867)
    at java.lang.Runtime.loadLibrary0(Runtime.java:870)
    at java.lang.System.loadLibrary(System.java:1122)
    at sun.tools.attach.LinuxVirtualMachine.<clinit>(bn:21101)
    at sun.tools.attach.LinuxAttachProvider.attachVirtualMachine(pf:55)
    at com.sun.tools.attach.VirtualMachine.attach(pj:10)
    at nul.IIIIIIiiIiII.const(yyb:54)
    at nul.iIiIIIiiiIII.run(zdc:90)

    Could it be that java is somehow not activating or its bypassing it somehow?

    EDIT: Checked to see where java was installed to make sure it was under library, and its usr/lib/jvm/ .I think it has to be under usr/local/lib/ but Im not sure how to move it
    Double EDIT: Didnt solve anything by moving the libattach.so to usr/local/lib/
    --- Double Post Merged, May 2, 2016, Original Post Date: May 2, 2016 ---
    I just said fuck it and signed up for googles cloud trial and am running windows now. Works like a charm. Thanks for the help any way?

Share This Page