Development in Eclipse?

Discussion in 'Programming & Hardware' started by Exile, Jul 26, 2014.

  1. Hi,

    I am a PHP developer with 8 years of experience, and studying Java @ highschool. I wanted to start developing for RuneMate, so I studied one of the Open Source scripts bots here(I used the Varrock Tea Stealer by Cloud).

    The API seems pretty straightforward, except that I'm getting these errors in Eclipse(the underlined says undeclared variable). The imports are correct, they are the same from Cloud's script bot.
    Also when I start my script bot in RuneMate, I get a box popping up saying "Your RuneMate session has now ended."

  2. You need to right click your project and go to build path. You then need to click the button that says something like import external jar or library or whatever. Choose the runemate jar and you'll be good to go
  3. Hover your mouse over the error to see what it shows, also, I think getEventProcessor got replaced by getEventDispatcher so that could be one the reasons it is showing error, setIterationDelay got replaced by setLoopDelay and it seems you don't declared the runtime variable like:

    Code (Text):
    1. private StopWatch runtime = new StopWatch();
    Tell me if that helps you.
  4. The first thing to do is make sure the time on your clock is correct. If it isn't you need to fix it. Otherwise it implies that your computer couldn't connect to the website for some reason.
  5. Yea my time is correct, for my timezone, I don't know if I need to set a different timezone?
    I live in GMT+1(Brussels Time).

    Also whenever I boot the client I always have to wait 2 minutes because it's "Waiting for Reflection mapper" or something.
  6. Thats normal, almost everyone has to wait for that :)
  7. Are you running Windows operating system? If so there are two steps to diagnose the session expiration issue.

    • Open your time & date settings by clicking the time & date on your taskbar and clicking "Change date and time settings.
    • Make sure the time zone matches yours.
    • Click the Internet Time tab on the top and then Change Settings.
    • Hit Update Now

    • Verify the time is correct after the update.
    Exile likes this.
  8. @Arbiter I was testing it and apparently the fix for it being out of sync does work so I don't have any idea on this one.

Share This Page