Bug Error 831468. Unable to bind to the game client.

Discussion in 'Client & Site Support' started by Lead Coffin, May 9, 2022.

Tags:
  1. Lead Coffin

    Joined:
    Jun 8, 2015
    Messages:
    9
    Likes Received:
    1
    Hi, need some help with fixing the Runemate client. I am unable to run ANY bots. I get an error about being unable to bind to the game client. I've also tried running bots with runelite also and get the same issue.

    here is my logs.
    [Debug] C:\Users\matty\OneDrive\jagexcache is a cache root according to the registry.
    May 09, 2022 4:48:48 PM com.sun.javafx.application.PlatformImpl startup
    WARNING: Unsupported JavaFX configuration: classes were loaded from 'unnamed module @3e27ba32'
    Eclipse Adoptium)
    00:00:00 INFO Max. Heap: 4080MB
    00:01:10 INFO Downloading required x86 JDK for binding.
    00:01:24 INFO Attempting to start the official RuneScape client. If it does not open shortly please do so manually.
    00:01:24 INFO Checking for a new game client every second for two minutes or until one is found.
    00:01:28 INFO Found a new game instance after 3 seconds.
    00:02:01 SEVERE Failed to bind to the game client
    java.rmi.ConnectException: Connection refused to host: 192.168.0.129; nested exception is:
    java.net.ConnectException: Connection timed out: connect
    at java.rmi/sun.rmi.transport.tcp.TCPEndpoint.newSocket(TCPEndpoint.java:623)
    at java.rmi/sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:209)
    at java.rmi/sun.rmi.transport.tcp.TCPChannel.newConnection(TCPChannel.java:196)
    at java.rmi/sun.rmi.server.UnicastRef.newCall(UnicastRef.java:343)
    at java.rmi/sun.rmi.registry.RegistryImpl_Stub.lookup(RegistryImpl_Stub.java:116)
    at nul.iIiiIIiiiIiIii.IiIIIiiiIIIIiI(vja:71)
    at com.runemate.client.boot.Binder.iIiiiiiiIIiiiI(ifa:131)
    at nul.iiIiiIiiiiIiIi.IIIiIiiiIiiiii(wka:50)
    at nul.iiIiiIiiiiIiIi.IiIIIiiiIiiiiI(wka:493)
    at nul.iiIiiIiiiiIiIi.run(wka:427)
    Caused by: java.net.ConnectException: Connection timed out: connect
    at java.base/java.net.PlainSocketImpl.connect0(Native Method)
    at java.base/java.net.PlainSocketImpl.socketConnect(PlainSocketImpl.java:101)
    at java.base/java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:412)
    at java.base/java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:255)
    at java.base/java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:237)
    at java.base/java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
    at java.base/java.net.Socket.connect(Socket.java:609)
    at java.base/java.net.Socket.connect(Socket.java:558)
    at java.base/java.net.Socket.<init>(Socket.java:454)
    at java.base/java.net.Socket.<init>(Socket.java:231)
    at java.rmi/sun.rmi.transport.tcp.TCPDirectSocketFactory.createSocket(TCPDirectSocketFactory.java:40)
    at java.rmi/sun.rmi.transport.tcp.TCPEndpoint.newSocket(TCPEndpoint.java:617)
    ... 9 more
    00:02:01 SEVERE An unspecified error occurred while attempting to bind to the game client (code 831469). Please restart RuneMate and try again, or seek support if the problem persists.
    --- Double Post Merged, May 9, 2022, Original Post Date: May 9, 2022 ---
    I've tried the thread fixes already fyi. Deleting the cache files etc, no luck.
     
  2. jessy kate

    Joined:
    Mar 10, 2020
    Messages:
    1
    Likes Received:
    0
    same issue here, is runemate down? For some reson it cannot connect to client and says runelite is temprarily disabled for the last few days. Please explain
     
  3. Lead Coffin

    Joined:
    Jun 8, 2015
    Messages:
    9
    Likes Received:
    1
    my issue seemed to be around my firewall. Works fine when i disable it.
     

Share This Page

Loading...