Resolved Ever since todays update(rs3)

Discussion in 'Client & Site Support' started by Velozity, May 11, 2015.

  1. I havent been able to run scripts bots, any script bot that is, I've tried multiple and none will work. Is anyone else experiencing this too? I have honestly no idea why this is happening to me, people in chat says its just fine.



    Oh and if this is the wrong sub, please move my thread to where it should be, I'm looking for answers or people who got the same issues!
     
  2. Yeah, getting the same issue with some bots. Unsure why it's occurring.
     
  3. I'm glad its not only me then, hopefully Cloud or Arbiter could post their thoughts on this, any scripter for that matter
     
  4. Some or all?
     
  5. @Cloud
    @Arbiter

    Equipment.getItems() is dead since the last RS update.it returns null when i try to get an equipment.i have to re-wear it to make it work.

    First time i log in it returns null until i re-wear it.

    ->Login handler
    ->Lobby handler
    ->onLoop()
    ->Equipment.getItems("something").interact("something"); ->returns null

    I pause the bot,i remove the "something" equipment and then i wear it.I resume the bot and it no longer returns null.
     
  6. Oh yeah, celestial fisher wont run either. I tried the lite version.
     
  7. Celestial Hunter's working just swell :)
     
  8. Iirc the equipment isn't updated on the fly like the inventory is, the tab has to be open for it to update.
    Also that last line should either throw a NPE or return true/false instead of returning null
     
  9. Yeah,it returns NPE :)

    The equipment tab is opened but the API can't find the equipment until i do what i mentioned above
     
  10. What was wrong with it?
     
  11. Does the equipment tab in the Dev kit reinforce this?

    As far as I'm concerned, it's a client bug, and I dunno how to fix it properly, but I'm interested in finding out more about it :p
     
  12. I can find it in the dev toolkit,but:
    Bounds: null
    seems like that's the problem :)
     
  13. It just stands there doing nothing upon start, just like every other script bot
     
  14. Mass Fighter was working fine, Alpha Magic wasn't.
     
  15. Well, I'm running both RS3 and OSRS bots right now.
     
  16. What rs3 bot are you running if I may ask? I'll try and see if it works for me
     
  17. Well, I'm not forcing you to pay me..

    [​IMG]
     
  18. Well, I'll take that risk and if its not working then its got to be me lol
     
  19. Getting this when I try to start Alpha Magic

    java.lang.NullPointerException
    at com.alpha.api.util.SettingsManager.lambda$loadSettings$83(SettingsManager.java:87)
    at com.alpha.api.util.SettingsManager$$Lambda$433/1236867924.accept(Unknown Source)
    at java.util.stream.ForEachOps$ForEachOp$OfRef.accept(Unknown Source)
    at java.util.stream.ReferencePipeline$2$1.accept(Unknown Source)
    at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(Unknown Source)
    at java.util.stream.AbstractPipeline.copyInto(Unknown Source)
    at java.util.stream.AbstractPipeline.wrapAndCopyInto(Unknown Source)
    at java.util.stream.ForEachOps$ForEachOp.evaluateSequential(Unknown Source)
    at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(Unknown Source)
    at java.util.stream.AbstractPipeline.evaluate(Unknown Source)
    at java.util.stream.ReferencePipeline.forEach(Unknown Source)
    at com.alpha.api.util.SettingsManager.loadSettings(SettingsManager.java:74)
    at com.slashnhax.bots.alpha.alpha_magic.ui.AlphaMagicGUI.<init>(AlphaMagicGUI.java:35)
    at com.slashnhax.bots.alpha.alpha_magic.AlphaMagic.lambda$init$137(AlphaMagic.java:11)
    at com.slashnhax.bots.alpha.alpha_magic.AlphaMagic$$Lambda$418/1014843718.run(Unknown Source)
    at com.sun.javafx.application.PlatformImpl.lambda$null$170(Unknown Source)
    at com.sun.javafx.application.PlatformImpl$$Lambda$55/505994169.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at com.sun.javafx.application.PlatformImpl.lambda$runLater$171(Unknown Source)
    at com.sun.javafx.application.PlatformImpl$$Lambda$54/1650790840.run(Unknown Source)
    at com.sun.glass.ui.InvokeLaterDispatcher$Future.run(Unknown Source)
    at com.sun.glass.ui.win.WinApplication._runLoop(Native Method)
    at com.sun.glass.ui.win.WinApplication.lambda$null$145(Unknown Source)
    at com.sun.glass.ui.win.WinApplication$$Lambda$43/1532409725.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
     
  20. I'll refund you if it doesn't work.
     

Share This Page

Loading...