Resolved Failed to bind to the game client because "Session has expired"

Discussion in 'Client & Site Support' started by Shimmy, Jul 12, 2016.

  1. So basically this bug happens.
    First of all, it's really hard to open Spectre, as many times I am suppoed to relaunch in order for it not to freeze during log in screen.

    Another thing that happens after I've bypassed the log-in issue, is that I have to re-enter my account details EVERY time I open runemate.

    And after I've got that far, it usually gives me the error above or that IOException error.
    I just re-installed my java and runemate, this bug still happens.

    Please help me resolve this.

    Here's the log:
    [Debug] RuneMate Version: 2.2.8
    [Debug] Java Version: 8u92 x86 (Oracle Corporation)
    [Debug] Operating System: Windows 8.1 x64
    java.lang.IllegalStateException: Not a JSON Object: null
    at nul.IIiIIIiiiIII.null(wqb:119)
    at nul.iIiIIIiIiiiI.getProperty(ccb:114)
    at nul.iIiIIIiIiiiI.getProperty(ccb:182)
    at nul.IIiIiIiiiIii.null(vlb:65)
    at nul.IIIIIIiiiiIi.else(npa:6023)
    at java.lang.Thread.run(Thread.java:745)

    [Notice] Your bot list has been refreshed.
    Attempting to start official client. If it does not open shortly please do so manually.
    Checking for a new game instance every second for two minutes or until one is found.
    Attempting to start official client. If it does not open shortly please do so manually.
    Checking for a new game instance every second for two minutes or until one is found.
    Found a new game instance after 5 seconds.
    Found a new game instance after 12 seconds.
    javafx.fxml.LoadException:
    /C:/Users/Garri%20Laube/RuneMate/temp/813964722.res

    at javafx.fxml.FXMLLoader.constructLoadException(FXMLLoader.java:2601)
    at javafx.fxml.FXMLLoader.loadImpl(FXMLLoader.java:2579)
    at javafx.fxml.FXMLLoader.loadImpl(FXMLLoader.java:2441)
    at javafx.fxml.FXMLLoader.load(FXMLLoader.java:2409)
    at nul.IIiiiiiIIiii.null(ed:23)
    at nul.IIiiiiiIIiii.null(ed:133)
    at nul.IiIiIIiiiIiI.<init>(fpa:184)
    at nul.IIIIIIiIIIii.null(ysa:15038)
    at nul.iiIiIIiiiiIi.null(tta:223)
    at nul.iIIIiIiiIiii.null(npa:18425)
    at nul.iIIIiIiiIiii.call(npa:5328)
    at javafx.concurrent.Task$TaskCallable.call(Task.java:1423)
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    at java.lang.Thread.run(Thread.java:745)
    Caused by: java.lang.IllegalArgumentException: The cloud constant Video-Ad-Skip-Threshold is unavailable.
    at nul.IIIIIIiiIiIi.final(nla:50)
    at nul.IIIIIIiiIiIi.get(nla:40)
    at java.util.concurrent.ConcurrentHashMap.containsKey(ConcurrentHashMap.java:964)
    at nul.IiIiIIiiiIiI.initialize(fpa:94)
    at javafx.fxml.FXMLLoader.loadImpl(FXMLLoader.java:2548)
    ... 12 more
    An error has occurred, dumping some debug information. has expired: false
    Failed to bind to the game client because "Session has expired."
    java.lang.NullPointerException
    at nul.IiIiIIiiiIiI.onSkipHyperlinkClicked(fpa:39)
    at nul.IiIiIIiiiIiI.final(fpa:228)
    at com.sun.javafx.application.PlatformImpl.lambda$null$173(PlatformImpl.java:295)
    at java.security.AccessController.doPrivileged(Native Method)
    at com.sun.javafx.application.PlatformImpl.lambda$runLater$174(PlatformImpl.java:294)
    at com.sun.glass.ui.InvokeLaterDispatcher$Future.run(InvokeLaterDispatcher.java:95)
    at com.sun.glass.ui.win.WinApplication._runLoop(Native Method)
    at com.sun.glass.ui.win.WinApplication.lambda$null$148(WinApplication.java:191)
    at java.lang.Thread.run(Thread.java:745)

    An error has occurred, dumping some debug information. has expired: false
    Failed to bind to the game client because "Session has expired."
     
  2. After doing some testing, this problem seems to be related to network issues, since it works with my mobile hotspot I created, however not with the wifi im connected to. No idea where the problem might lay thou.
     
  3. Potential port forwarding issues, firewalls etc
     
  4. Can this be fixed on my end or do I have to contact the network provider?
    --- Double Post Merged, Jul 12, 2016, Original Post Date: Jul 12, 2016 ---
    @Arbiter please helppp
     
  5. Port forwarding is configured on your modem/router.

    Google your modem name + "port forwarding" to find out how to do it.

    Your firewall settings are within your computer's settings.

    So yes, you can make the changes from your end.
     
  6. Yeah, but everything was okay, and then suddenly it "broke".
    I have no idea how to fix it, meaning what to change or do with that port forwarding. I've tried from 3 different places - my home network, workplace and also my gf's house, all have the same problem...
    Really hope someone knows whats up with this
     
  7. There is very little support we can provide in terms of networking. There are quite a few things it can be and all of them are specific to your configuration. I would recommend starting with a network sniffer and attempting to isolate. I would see if there were dropped connections and then trying to figure out if they are specific to RuneMate or occur on other sites as well. If you don't have the time to invest in it you can always report it to your ISP who could very easily be to blame, especially if you didn't change anything and it started giving you trouble randomly.
     
  8. It's me again, with the same issue.
    So I just tested and it works fine in my girlfriend's house. Yet here, at home, it still doesn't work.
    When I run as an administrator, it just freezes the log-in screen. If I run it normally, it logs in, however doesn't load any bots unless I hit refresh. After I've hit refresh, it loads all the bots, but none of the saved accounts, that's how I know the error is gonna happen.

    Are there any logs or smth I can provide to make the problem clearer? I don't mean to be egoistic, but this problem has occured for well over a month now and I've reinstalled everything like 5 times.

    Please help.. :)
     
  9. Using the same computer at your and your girlfriend's house? Or a different computer at each location?

    Runemate > Help > View logs is where you will find your log files.

    If you are using the same computer at your girlfriend's house and your house, and it works at your girlfriend's house but not your house, I would suspect it is a networking issue at your place causing the problem.
     
  10. Same computer, have already stated that it is a network issue. However I have no idea how to fix it, nor what steps to take, to fix it? Do I just have to call my internet provider and tell him, that RuneMate doesn't work, or how to adress the problem more specifically.
     
  11. My bad, forgot to read the rest of the thread.

    Try a different modem/router at your home address. See if that works for you as an easy first step.
     
  12. Basically, where I'm from, there are 2 internet providers, we have the exact same modem and the same deal (network speed), however the location is different.
     
  13. If you both have the same model modem, they could still be configured differently.

    Next time you can, I would take a look and screenshot the settings on your girlfriend's "working" modem and make sure the settings on your own modem are not different - or if there are different settings post them here.

    Another thing you could try is a traceroute test.

    At your location run a tracert for "www.runemate.com"

    and run the same tracert for "www.runemate.com" at your girlfriend's location. Use the same computer at both locations.

    Here's how to do a tracert:
    How do I run a traceroute?
     
  14. Ooh thank you so much, as soon as I can, i will run the test and let you know of the results :)
     
  15. Be sure to thank @Party for the suggestion ;)
     
  16. same problem. Most likely closed port, but i can't find which port runemate uses...
     
  17. The client update somehow resolved the issue.
    Does any1 have any idea why?
     

Share This Page

Loading...