Bug Failed to download or unpack the bot

Discussion in 'Client & Site Support' started by Xanduney, Jun 14, 2016.

  1. Hey I woke up this morning and went to start runemate and I cant start any bots. when I try to start AlexH666's Smelter i get the error " Failed to download or unpack the bot" and will not let me close that bot without restarting runemate. [​IMG]
    When i try with other bots such as alpha magic, i get no error at all, it just starts and runs until the gui should pop up and just sits there like this [​IMG]

    Would be glad to provide any extra information that might be necessary. I have also attatched a log file. Any help would be greatly appreciated. Thanks
     

    Attached Files:

  2. If you are only getting this issue with one bot - @AlexH666's smelter - then this is likely an issue with their bot in particular.

    Recommend you uninstall Runemate and Runescape from your computer, and reinstall them with a fresh download.
     
  3. Thanks Kaze i will give that a try real quick. The smelter is the only one that actually gives me an error. but nothing else starts
     
  4. @kazemanie I don't believe this is an issue with my bot.
    It works.

    He has issues with all bots.
     
  5. Correct
    --- Double Post Merged, Jun 14, 2016, Original Post Date: Jun 14, 2016 ---
    Also, just tried reinstalling and its still giving me the error
     
  6. Ah I see, my mistake.

    Hopefully you can get this resolved quickly :)
     
  7. @Cloud


    Sent from my iPhone using Tapatalk
     
  8. Having the same issue.

    This is the log:
    Code (Text):
    1. java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:
    2.     java.rmi.RemoteException: Unable to reflect sw.nh; nested exception is:
    3.     java.lang.NoSuchFieldException: nh
    4.     at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:353)
    5.     at sun.rmi.transport.Transport$1.run(Transport.java:177)
    6.     at sun.rmi.transport.Transport$1.run(Transport.java:174)
    7.     at java.security.AccessController.doPrivileged(Native Method)
    8.     at sun.rmi.transport.Transport.serviceCall(Transport.java:173)
    9.     at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:553)
    10.     at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(TCPTransport.java:808)
    11.     at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:667)
    12.     at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
    13.     at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
    14.     at java.lang.Thread.run(Thread.java:722)
    15.     at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(Unknown Source)
    16.     at sun.rmi.transport.StreamRemoteCall.executeCall(Unknown Source)
    17.     at sun.rmi.server.UnicastRef.invoke(Unknown Source)
    18.     at java.rmi.server.RemoteObjectInvocationHandler.invokeRemoteMethod(Unknown Source)
    19.     at java.rmi.server.RemoteObjectInvocationHandler.invoke(Unknown Source)
    20.     at com.sun.proxy.$Proxy7.uid(Unknown Source)
    21.     at nul.IiIiIIiiIiiI.goto(tla:22)
    22.     at com.runemate.game.api.hybrid.region.Players.getLocal(ixa:59)
    23.     at nl.mmaaikel.mmaaikelrunecrafter.MmaaikelRunecrafter.<init>(MmaaikelRunecrafter.java:68)
    24.     at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    25.     at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    26.     at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    27.     at java.lang.reflect.Constructor.newInstance(Unknown Source)
    28.     at java.lang.Class.newInstance(Unknown Source)
    29.     at nul.IiiIiIiIiiiI.goto(fra:189)
    30.     at nul.IiIIiIiIIIIi.catch(jdb:246)
    31.     at nul.iIIiiIiiiiiI.run(qya:253)
    32. Caused by: java.rmi.RemoteException: Unable to reflect sw.nh; nested exception is:
    33.     java.lang.NoSuchFieldException: nh
    34.     at aux.iiIIIiiIII.void(ic:799)
    35.     at aux.iiIIIiiIII.void(ic:816)
    36.     at aux.iiIIIiiIII.uid(ic:339)
    37.     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    38.     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    39.     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    40.     at java.lang.reflect.Method.invoke(Method.java:601)
    41.     at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:322)
    42.     at sun.rmi.transport.Transport$1.run(Transport.java:177)
    43.     at sun.rmi.transport.Transport$1.run(Transport.java:174)
    44.     at java.security.AccessController.doPrivileged(Native Method)
    45.     at sun.rmi.transport.Transport.serviceCall(Transport.java:173)
    46.     at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:553)
    47.     at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(TCPTransport.java:808)
    48.     at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:667)
    49.     at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
    50.     at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
    51.     at java.lang.Thread.run(Thread.java:722)
    52. Caused by: java.lang.NoSuchFieldException: nh
    53.     at java.lang.Class.getDeclaredField(Class.java:1899)
    54.     at aux.iiIIIiiIII.void(ic:891)
    55.     ... 17 more
    56. Failed to download or unpack the bot.
    57.  
     
  9. I just got hit by the same issue this morning :(
     
  10. Any update on this issue?
     
    Mmaaikel likes this.
  11. Still not working for me either this morning.
    Tried reinstalling everything and also tried it on my laptop, which didn't work either :(

    I'm sure they will come with a fix soon tho :)
     
  12. I need the gamepack ids that are experiencing this problem.
     
  13. This may be a question answered somewhere else, but I didn't get any hits on a forum search. Where do we find the gamepack id? I've looked through some of the logs and game files, but I'm not sure where it is.
     
  14. Try this:

    What is your gamepack ID? It should show up right before the game finishes loading

    Resolved - Bots aren't running
     
  15. I don't see the loading message everyone seems to be referring to, even looking for the one in this screenshot. I never get a message about syncing with the cloud (unless it loads so fast that I don't see it) and I'm unable to find anything labeled as 'gamepack' in the logs unless it's called something else.

    Sorry if this is something obvious, just curious as to what I'm missing.

     
  16. I'm not entirely sure if the gamepack ID is shown there as that information was last posted in September, and Runemate has evolved since then.

    I'm sure a staff member will be able to help you further with the technical side of things.
     
  17. Thanks for trying to help. I'm passing the time going through the tutorials they have for creating your own bots so no rush.
     
  18. Yea im not seeing it either :/
     

Share This Page

Loading...