Resolved Firewall Error when opening up Runemate from inside IntelliJ

Discussion in 'Developer Support' started by orbitance, Oct 16, 2016.

  1. Pretty much title, I am unable to login to Runemate when I to run it from inside IntelliJ Idea. I'm learning to create bots and this is kind of frustrating, since I am unable to test anything out. All help is appreciated.

    Important to note, that I can run runemate, and login in to my account, when I run it outside of IntelliJ, another thing to note is that I can login when I change my jre to 64bit, however when I try to run a bot it tell me the error is that client can not be attached, and tell me to run with 32bit JRE.
     
  2. Best Answer:
    Post #2 by Aidden, Oct 16, 2016
  3. You could try adding runemate and intellij to your firewalls exception list. If you don't want to do that or it doesn't work you can just run runemate through cmd with the -sdk argument and that will run local bots just the same as it will by running through intellij.
     
  4. This got me into developer mode, however now I can no longer see my bots on the side bar :c

    Adding to the firewall didn't work either Q_Q
     
    #3 orbitance, Oct 16, 2016
    Last edited: Oct 16, 2016
  5. You need to set the local bot directory in your spectre settings. Set it to your out folder in your project.
     
  6. I changed it to the out folder, it still hasnt picked up on my hello world bot :c
    upload_2016-10-16_18-22-39.png

    note the bot could be seen on the side,bar when I was using 64 JRE
     
  7. Try recompiling the project and check inside the out folder to make sure all the classes are there.
     
  8. Legend, recompiling the bloody project worked <3. Hopefully I can be a bot author soon :)
     
  9. I look forward to seeing your bots :)
     
    orbitance likes this.

Share This Page

Loading...