Resolved Inventory items detection issue?

Discussion in 'Client & Site Support' started by paulsniper19, Sep 6, 2015.

  1. Hi,

    Note: This is regards to EoC.

    Is anyone else experiencing the same issue of the combat bots (or whatever bot that utilises the inventory) not being able to eat or alch? Please let me know if anyone is currently working on the solution if this is indeed a global issue. Thanks in advanced.


    EvilCabbage likes this.
  2. Best Answer:
    Post #17 by Cloud, Sep 9, 2015
  3. Yeah I'm having the same issue actually.
    It works if you change your interface style to legacy mode, but it's like it doesn't recognize that it's in modern style.
    I haven't run a check on what interface style it's returning, but I'm guessing that it only can see it as being in legacy style, so it uses legacy style interfaces.
  4. okay, do you know if it works for alching as well? or just eating?
  5. Well I'm only assuming it will work for your purposes, I was specifically having it lay box traps and it would interact with them if you switch your interface style to legacy.
    You can try it out yourself to see if it works.
  6. okay thanks very much Coder :)
  7. No problem pal.
    @Cloud should be able to chime in on what the issue may be whenever he gets on
  8. okay, so I tried it with legacy interface mode; it eats now, however, it does not alch since it's trying to activate using the action bar (using the keybinded action). It won't go to the magic tab, select High alch, then click on the item. So the bot is just stuck on "Alching"... oh well...yes let's hope that @Cloud will be able to shine some light on the situation :)
  9. I've encountered this bug when on @someoneelse 's account. Strangely, it only happens to a couple accounts, as my account never encountered that issue. Changing to the default RS3 EOC interface did not fix it, but changing to Legacy works, as some other people have pointed out.

    InterfaceWindows.getInventory().isOpen() returns false in EOC.

  10. I have the same issue :/ I informed cloud about it via slack so he knows about it :)
  11. Confirming what @Aria said about it being account specific. Happens to @Coder but not to me using the same bot.
  12. sucks, cant use anything that touches inventory :( RIP EXP
  13. It does work when you have to click the inventory items directly yes, but it still does not solve the other issues like High Alchemy and other tasks which require more than one click.
  14. It must be because of the highly customize-able RS3 interface, that's the only thing that can differ per account what would mess with item interaction I would say. And I don't mean dragging the inventory around in your inventory but enabling stuff such as ribbons and title bars hidden.
    paulsniper19 likes this.
  15. It's due to the way the Inventory interface is being detected. It's an issue I have with my accounts as well, although other accounts work fine on my pc.
  16. Can you detect any similarities with the accounts that work, in terms of interface setup, etc.? If so, then that might help in allowing us (the ones who are experiencing the problem) to be able to use Non-Legacy Interface Mode once again.
  17. Fixed it on another account Slashnhax provided to me, if it's still occuring on your accounts please contact me and send me a pm with the rs account information.
    Xanduney likes this.
  18. YAY! It's back to normal now! :D Thank you @Cloud . Someone mark this as resolved please.

Share This Page