Bug IOException

Discussion in 'Client & Site Support' started by Krosden, Sep 24, 2016.

  1. I've seen numerous posts of this problem, and how @Cloud can fix it. Messaged him and haven't gotten a reply in a number of days so here's what I've tried.

    Copied from my chat with @Cloud
    "I'm getting a "Failed to bind the game client because of an IOException" error. Uninstalled both 32-bit and 64-bit java and reinstalled ONLY 32-bit and ONLY 64-bit separately at different times. I've run the oldschool client in administrator mode. I read on the forums that this could be a gamepack ID issue and to contact you, however I must be blind as I can't find my ID anywhere :("

    Since that message I have also uninstalled all versions of java, reinstalled only 32-bit, and installed the runemate windows client instead of running the standalone .jar file. No help.
    Would Virtualisation in my BIOS have any effect? (Currently turned off).

    Here's my log; it mentions that WindowsVirtualMachine is having trouble, however I'm not running Spectre in a virtual machine.

    [Debug] RuneMate Version: 2.3.5
    [Debug] Java Version: 8u92 x86 (Oracle Corporation)
    [Debug] Operating System: Windows 10 x64
    Sep 25, 2016 4:12:00 PM java.util.prefs.WindowsPreferences <init>
    WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
    Attempting to start official client. If it does not open shortly please do so manually.
    Checking for a new game instance every second for two minutes or until one is found.
    Found a new game instance after 81 seconds.
    Failed to bind to the game client because of a IOException
    java.io.IOException: Access is denied
    at sun.tools.attach.WindowsVirtualMachine.openProcess(Native Method)
    at sun.tools.attach.WindowsVirtualMachine.<init>(hz:133)
    at sun.tools.attach.WindowsAttachProvider.attachVirtualMachine(hv:104)
    at com.sun.tools.attach.spi.AttachProvider.attachVirtualMachine(jp:3)
    at com.sun.tools.attach.VirtualMachine.attach(xp:4258)
    at nul.iIiIiIiiIiII.false(ckb:178)
    at nul.iIiIiIiiIIii.run(amb:168)
    --- Double Post Merged, Sep 27, 2016, Original Post Date: Sep 24, 2016 ---
  2. Run RuneMate as administrator and it should work fine. At least, it did for me.
  3. Ah, run both Runemate and the Runescape client as administrator respectively, forgot to mention.
    --- Double Post Merged, Oct 8, 2016, Original Post Date: Oct 1, 2016 ---
    Ah well my other computer runs Spectre alright so dw guys :/

Share This Page