Question Issue Running Spectre

Discussion in 'Client & Site Support' started by hjalali13, Apr 18, 2016.

Tags:
  1. When I try to get the RS3 client running (I have the official Runescape client installed), I get a prompt telling me "You'll need a new app to open this Jagex-Jav". Then it gives me the option to look for one in the Microsoft Store. Is there a fix for this?
     
  2. See this thread for common issues:
    Tutorial - Runemate Spectre – Common Issues & Troubleshooting | Community | RuneMate

    You need to download the official Runescape client from the official Runescape website.
     
  3. Moved to correct section (Client support).
     
  4. Tutorial - How to Use RuneMate Spectre | Community | RuneMate

    Re-read the updated instructions particularly the section that talks about which official client to download.

     

Share This Page

Loading...