Resolved [Linux/Arch/KDE/RSU] Error on Start Instance press

Discussion in 'Developer Support' started by SlashnHax, Feb 13, 2016.

  1. Code (Text):
    1. Exception in thread "Alpha Agility - redacted" java.lang.NullPointerException
    2.  at nul.iIIiiIiIiIii.<init>(shb:9)
    3.  at nul.iIIiiIiIiIii.<init>(shb:177)
    4.  at nul.IiIIiIiiiiII.run(bbc:102)
    5. Exception in thread "Alpha Dev Kit - redacted" java.lang.NullPointerException
    6.  at nul.iIIiiIiIiIii.<init>(shb:9)
    7.  at nul.iIIiiIiIiIii.<init>(shb:177)
    8.  at nul.IiIIiIiiiiII.run(bbc:102)
    9. Exception in thread "Alpha Fighter - redacted" java.lang.NullPointerException
    10.  at nul.iIIiiIiIiIii.<init>(shb:9)
    11.  at nul.iIIiiIiIiIii.<init>(shb:177)
    12.  at nul.IiIIiIiiiiII.run(bbc:102)
    13. Exception in thread "Example Powerchopper - redacted" java.lang.NullPointerException
    14.  at nul.iIIiiIiIiIii.<init>(shb:9)
    15.  at nul.iIIiiIiIiIii.<init>(shb:177)
    16.  at nul.IiIIiIiiiiII.run(bbc:102)
    17. Exception in thread "Flag Checker - redacted" java.lang.NullPointerException
    18.  at nul.iIIiiIiIiIii.<init>(shb:9)
    19.  at nul.iIIiiIiIiIii.<init>(shb:177)
    20.  at nul.IiIIiIiiiiII.run(bbc:102)
    21. Exception in thread "Viewer's Bounds Editor - redacted" java.lang.NullPointerException
    22.  at nul.iIIiiIiIiIii.<init>(shb:9)
    23.  at nul.iIIiiIiIiIii.<init>(shb:177)
    24.  at nul.IiIIiIiiiiII.run(bbc:102)
    25.  
    Spectre was run with sudo java -jar spectre.jar -sdk
    All bots except for Viewer's Bounds Editor are local.
    --- Double Post Merged, Feb 14, 2016, Original Post Date: Feb 13, 2016 ---
    The exact same error occurs for me on Windows as well.
    --- Double Post Merged, Feb 14, 2016 ---
    Seems to be a nullpointer related to setting an EmbeddableUI with a property with a null value.

     
  2. Best Answer:
    Post #10 by Cloud, Feb 17, 2016
  3. @Arbiter I find it somewhat insecure that our RS usernames get displayed in every exception.

    @SlashnHax if it is related to a null value in the bot interface ObjectProperty, you might aswell just unimplement EmbeddableUI, or alternatively pass new Text("") to represent an empty node.
     
  4. I passed in new VBox() to represent the empty node xD
    --- Double Post Merged, Feb 14, 2016, Original Post Date: Feb 14, 2016 ---
    I fixed it on Windows by initializing the objectproperty with a new VBox(), the error still occurs on Linux though.
     
  5. Please confirm that this problem still persists in the next (unreleased) version, 1.11. I am not sure my latest commit has made it live yet.
    I agree that exceptions shouldn't have the RS account, especially considering it'll be sent to the server. @Cloud
     
  6. The exceptions don't have anything related to the rs account included, the problem is the thread naming is done based on the rs-account name to make debugging purposes either when working on machines running multiple clients at once.
     
  7. Would it be possible to generate some sort of instance id and use that instead? Or could you use the PID for this?
     
  8. I suppose I can change it to pid - bot name instead of bot name - account name
     
  9. Fixed by loading darkscape and then loading rs3 again.
    Seems there's an issue with my codebases where it detects my rs3 as darkscape, but since I hadn't run darkscape, it didn't like stuff.
     
  10. So what's the resolution on the original issue @SlashnHax @Cloud?
     

Share This Page

Loading...