List of Command Line Arguments

Discussion in 'Tutorials & Resources' started by Cloud, Apr 25, 2014.

  1. Code (Text):
    1. -login={username}:{password}:{OSRS||RS3}
    2. Example: -login=example:password:RS3
    Bypasses the login screen (if the credentials are valid) and initializes the specified game.
    Code (Text):
    1. -bot="name of bot here"
    2. Example: -bot="Cloud's Powerchopper"
    Starts the specified bot as soon as the game begins to load.
    Code (Text):
    1. -account="The account's login name/email here"
    Starts the specified bot with the specified account as soon as the game begins to load. If a bot isn't specified with the "-bot" flag, this flag will be ignored.
    Code (Text):
    1. -sdk
    Enables development mode within the client and provides access to the developer toolkit.
    Code (Text):
    1. -world=123
    Starts with the preferred world set to the specified world.
    Code (Text):
    1. -proxy={host}:{port}:{username}:{password}
    Uses the specified proxy, username and password are optional.
    Code (Text):
    1. -dimensions=123x123
    Sets the initial bounds of the game's canvas.
    #1 Cloud, Apr 25, 2014
    Last edited: Oct 22, 2015
    Geashaw, Qosmiof2 and Exia like this.
  2. I'm entering -login={username}:{password}:{RS3}
    and I get the message

    Please enter a valid GameType [RS3 or OSRS]
  3. I apologize that the instructions were unclear, I added an example to the top post
  4. I get an error saying Unable to invoke main method when i try to add the autologin command.
  5. Here's the error from above

    Code (Text):
    1. (08:15:35) [Debug] Started with java 1.7.0_67
    2. (08:15:38) Couldn't properly initialize loading canvas resources
    3. (08:15:38) [Setup] Downloading game...
    4. (08:15:38) Exception in Application start method
    5. (08:15:38) Exception in runnable
    6. java.lang.NullPointerException
    7.         at
    8.         at com.sun.javafx.application.PlatformImpl$4$ Source)
    9.         at com.sun.javafx.application.PlatformImpl$4$ Source)
    10.         at Method)
    11.         at com.sun.javafx.application.PlatformImpl$ Source)
    12.         at$ Source)
    13.         at Method)
    14.         at$100(Unknown Source)
    15.         at$3$ Source)
    16.         at Source)
    17. (08:15:38) Workaround until RT-13281 is implemented: keep toolkit alive
    18. java.lang.reflect.InvocationTargetException
    19.         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    20.         at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    21.         at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    22.         at java.lang.reflect.Method.invoke(Unknown Source)
    23.         at com.javafx.main.Main.if(tpb:606)
    24.         at com.javafx.main.Main.main(tpb:929)
    25. Caused by: java.lang.RuntimeException: Exception in Application start method
    26.         at com.sun.javafx.application.LauncherImpl.launchApplication1(Unknown So
    27. urce)
    28.         at com.sun.javafx.application.LauncherImpl.access$000(Unknown Source)
    29.         at com.sun.javafx.application.LauncherImpl$ Source)
    30.         at Source)
    31. Caused by: java.lang.IllegalStateException: Location is not set.
    32.         at javafx.fxml.FXMLLoader.load(Unknown Source)
    33.         at com.runemate.a.e.aUx.<init>(wgb:53)
    34.         at com.runemate.a.e.CON.<init>(wgb:115)
    35.         at com.runemate.cON.start(wsb:204)
    36.         at com.sun.javafx.application.LauncherImpl$ Source)
    37.         at com.sun.javafx.application.PlatformImpl$ Source)
    38.         at com.sun.javafx.application.PlatformImpl$4$ Source)
    39.         at com.sun.javafx.application.PlatformImpl$4$ Source)
    40.         at Method)
    41.         at com.sun.javafx.application.PlatformImpl$ Source)
    42.         at$ Source)
    43.         at Method)
    44.         at$100(Unknown Source)
    45.         at$3$ Source)
    46.         ... 1 more
  6. This is awesome!
  7. Where do we save these?
  8. Open notepad and paste it in there after java -jar RuneMate.jar. Save it as namehere.bat and set save as type to all files. Then instead of clicking on the runemate jar, run the bat file and it will load the client with the specified settings
  9. Thanks, what should in front of it again?

    I have it like this atm:

    java -jar RuneMate.jar-login=username:password:RS3
  10. When I run the bot and include -bot and -account, the message listener stops working. However, if I do not include -bot and -account the message listener works without any problems.

    Its actually -bot thats reponsible. For somereason if bot start with client, messagelistener just wont work.
    #11 countvidal, Feb 11, 2015
    Last edited: Feb 12, 2015
  11. Bug report for @Cloud.
  12. Any news if anyone else has been able to replicate this bug? @Arbiter @Cloud
  13. I haven't seen any one else report issues with it. Are you 100% sure the -bot argument is the issue? It uses the same startup code as the setup dialog.
  14. I have narrowed it down to just that. Message listener works perfectly when I dont include -bot:"nameofscript". When I do include it, just putting a println on onmsgrcvd doesnt print anything. It is so weird.
  15. Without -Bot args works perfectly.


    With -bot args fails:


    @Cloud @Arbiter
  16. Hmm alright, I didn't experience the issue but one slight difference I noticed was you entered an invalid account name in the arguments. Try entering a valid one and report if that changes anything at all, that should have been the only difference between our tests.
  17. [​IMG]

    Nope still have a problem. @Cloud
  18. I've found the problem and have fixed it for the next release. It was something really small and subtle.
  19. Ok perfect, when is the next release?

Share This Page