Loading Local Scripts

Discussion in 'Developer Support' started by Exia, Aug 6, 2014.

  1. So I'm simply trying to get a script bot to show in the selector I have:
    scripts bots->BatFarmer.class

    and then:
    scripts bots->BatFarmerManifest.xml
    which contains:
    <manifest>
    <main-class>scripts bots.BatFarmer</main-class>
    <name>Bat Farmer</name>
    <description>Does some Farming and shit</description>
    <version>1.0</version>
    <compatibility>
    <game-type>RS3</game-type>
    </compatibility>
    <categories>
    <category>FARMING</category>
    </categories>
    <!--The rest are optional-->
    <open-source>false</open-source>
    <production>true</production>
    <tags>
    </tags>
    <!--Required to publish on the bot store-->
    <internal-id>batfarmer</internal-id>
    </manifest>

    All I get is "Unable to load Bat Farmer".

    Edit:

    Oh yeah, all the script bot is is this:
    package scripts bots;

    import com.runemate.game.api.script bot.framework.LoopingScript;

    public class BatFarmer extends LoopingScript{

    @Override
    public void onLoop() {
    // TODO Auto-generated method stub

    }​

    }
     
    #1 Exia, Aug 6, 2014
    Last edited: Aug 28, 2014
    Philosobyte likes this.
  2. Make sure the xml is being output to the same location that your classes are.
     
  3. I know it's reading the xml since the name "Bat Farmer" comes up with the space as it is defined in the xml. It's just refusing to load the script bot for whatever reason. I'm going to try running the client as admin to see if that fixes it.
     
  4. Your main class in xml must be scripts bots.BatFarmer.BatFarmer

    First one is name of java file,
    Second one is actuql class name
     
  5. Still doesn't work.

    @Cloud can you add some more debug to the unable load [script bot NAME] statement that can indicate why it might not be loading.
    Things I've tried:
    Running as Admin
    Removing all optional tags
    Changing the category to make sure that it actually is valid
    Including both the .java and class name.
    Including and not including the package
    Using the the default script bot directory
    Using my own directory
    Placing the .java, .class, .xml all in the same directory

    Current Directory setup:
    [​IMG]

    A side note, I'm on windows 8 64-bit. I'll try updating java I guess.
     
  6. Create a folder in RuneMate/bots, name it "scripts bots".

    Move BatFarmer.class, BatFarmer.java & BatFarmerManifest.xml in that "scripts bots" folder.
     
  7. @Cloud see if you can Teamviewer with him and debug the problem faster. This is a blocker.
     
  8. Send me your teamviewer credentials on skype, I'm assuming your root folder is incorrect or something.
     
  9. It's unable to locate the main class, so I assume that your selecting the source folder instead of the class folder.
     
  10. I'll try it again, thanks for the tip.
     
  11. Thanks @Arbiter for fixing the issue, it was just something wonky with the way eclipse was saving the files I guess.
     
  12. I'm currently having problems wit h this too; probably due to my own stupidity. Can anyone help out at all? I think I've performed all the steps above.
     
  13. My issue had to do with the directory structure. I'll take a look when I get back home, but I think I needed a folder named bin or something.
     
  14. @Arbiter @Cloud @TheBat said to post here. I'm having the same problem and he wasn't able to fix it.
     
  15. @Arbiter, you should fix it so that he can develop the batminer with me.
     
  16. I'm out of commission until Thursday. Deferring to @Cloud to since the solution I found was likely temporary. This has to do with the custom class loader for SDK mode.
     
  17. @Arbiter, and what was the temporary solution?
     
  18. If I have to wait until Wednesday it isn't an issue. Finals are taking up a lot of my spare time at the moment. Just curious as to why it wouldn't be working.
     

Share This Page

Loading...