Resolved Not detecting rs instance

Discussion in 'Developer Support' started by Aidden, Feb 9, 2016.

  1. Used this to load the rs3 instance:

    Code (Text):
    2. "%ProgramFiles(x86)%\Java\jre1.8.0_73\bin\java.exe" -Dsun.java2d.nodraw=true -Dcom.jagex.config= -jar "%HOMEPATH%\jagexcache\jagexlauncher\bin\jagexappletviewer.jar" runescape
    And then loaded spectre via:

    Code (Text):
    2. "C:\Program Files (x86)\Java\jre1.8.0_73\bin\java.exe" -jar "C:\Users\aidden\RuneMate\spectre.jar".

  2. Best Answer:
    Post #13 by Cloud, Mar 8, 2016
  3. Cloud said spectre needs to load first, then the client. But it still doesn't work for me.
    Code (Text):
    2. java.util.ServiceConfigurationError: Provider could not be instantiated
    3. java.util.ServiceConfigurationError: Provider not found
    4. java.util.ServiceConfigurationError: Provider not found
    thats what it prints though.
  4. Fek. How did i forget that. Lel.

    RS3 instance:
    Code (Text):
    2. Error: client.init:1258 sun.reflect.NativeMethodAccessorImpl.invoke0 sun.reflect
    3. .NativeMethodAccessorImpl.invoke sun.reflect.DelegatingMethodAccessorImpl.invoke
    4.  java.lang.reflect.Method.invoke Rs2Applet.a:118 Rs2Applet.init:431 app.appletvi
    5. ewer.a:598 jagexappletviewer.main:78 | java.lang.RuntimeException |
    Code (Text):
    2. java.util.ServiceConfigurationError: Pr
    3. ovider could not be instantiated
    4. java.util.ServiceConfigurationError: Pr
    5. ovider not found
    6. java.util.ServiceConfigurationError: Pr
    7. ovider not found
    --- Double Post Merged, Feb 9, 2016, Original Post Date: Feb 9, 2016 ---
    Tried starting rs first as well as spectre first. Same result.
  5. Code (Text):
    1. WindowsAttachProvider could not be instantiated
    That's the problem, I wonder why that's happening.
  6. I also have this issue
  7. I also have this issue.
  8. Please try V1.0.1 and report the results. I'm expecting different output, not necessarily a fix.
  9. On os x:
    Code (Text):
    1. java.util.ServiceConfigurationError: Provider could not be instantiated
    2. java.lang.UnsatisfiedLinkError: Native library (com/sun/jna/darwin/libjnidispatch.jnilib) not found in resource path ([file:/Users/John/Runemate/spectre-1.0.1.jar])
    3. at com.sun.jna.Native.loadNativeDispatchLibraryFromClasspath(di:24086)
    4. at com.sun.jna.Native.loadNativeDispatchLibrary(di:8551)
    5. at com.sun.jna.Native.<clinit>(di:180)
    6. at com.runemate.system.osx.Carbon.<clinit>(jm:159)
    7. at nul.IiiiIIiiIIIi.try(uxb:138)
    8. at nul.IIiiIiiIIIIi.try(ti:35)
    9. at nul.IIiiIiiIIIIi.try(ti:269)
    10. at nul.IIiiIiiIIIIi.try(ti:200)
    11. at nul.iiiIiIiiIIiI.try(czb:65)
    12. at nul.IiIiIIiiIIii.initialize(mrb:154)
    13. at javafx.fxml.FXMLLoader.loadImpl(
    14. at javafx.fxml.FXMLLoader.loadImpl(
    15. at javafx.fxml.FXMLLoader.load(
    16. at nul.IiiIIiiIIIII.try(pj:83)
    17. at nul.IiiIIiiIIIII.try(pj:133)
    18. at nul.IiIiIIiiIIii.<init>(mrb:214)
    19. at nul.IiIiIIiiIIii.<init>(mrb:278)
    20. at nul.iiIIIIiIiiiI.try(unb:269)
    21. at nul.IiiiiIiIIIii.try(lob:22607)
    22. at
    23. at javafx.concurrent.Task$
    24. at
    25. at
    Code (Text):
    1. java.lang.NoClassDefFoundError: Could not initialize class com.runemate.system.osx.Carbon
    2. at nul.IiiiIIiiIIIi.try(uxb:138)
    3. at nul.IIiiIiiIIIIi.try(ti:35)
    4. at nul.IIiiIiiIIIIi.try(ti:269)
    5. at nul.IIiiIiiIIIIi.try(ti:200)
    6. at nul.iiiIiIiiIIiI.try(czb:65)
    7. at nul.IiIiIIiiIIii.initialize(mrb:154)
    8. at javafx.fxml.FXMLLoader.loadImpl(
    9. at javafx.fxml.FXMLLoader.loadImpl(
    10. at javafx.fxml.FXMLLoader.load(
    11. at nul.IiiIIiiIIIII.try(pj:83)
    12. at nul.IiiIIiiIIIII.try(pj:133)
    13. at nul.IiIiIIiiIIii.<init>(mrb:214)
    14. at nul.IiIiIIiiIIii.<init>(mrb:278)
    15. at nul.iiIIIIiIiiiI.try(unb:269)
    16. at nul.IiiiiIiIIIii.try(lob:22607)
    17. at
    18. at javafx.concurrent.Task$
    19. at
    20. at
  10. I got it working, i am using the JDK java.exe for spectre and the JRE java.exe for the RS client. Both version 8u74, 32bit.
  11. Have all of you now resolved this issue either by using a different combination of jre/jdk's or by updating to a newer version?
  12. I haven't yet. I tried what savior said but it didn't work. I'll try some more shortly, just replacing all my Filters with Predicates -.-
  13. Is anyone still having this issue?
    --- Double Post Merged, Mar 8, 2016, Original Post Date: Feb 29, 2016 ---
    I'm assuming that this issue has been resolved since nobody has commented saying they still have this issue.

Share This Page