Resolved Please wait until Runescape is logged in!

Discussion in 'Client & Site Support' started by Prodigy, May 12, 2015.

  1. I get the error " Please wait until Runescape is logged in! " when running one specific script bot. Jfletchers by Eagles13

    I know this is a problem specific to me and the computer I am using, because i tried running it on my vps, and it started without a hitch. Every other script bot that I have tried to run, works flawlessly and without any error of the sort.

    I have tried restarting my computer (not that I expected that to work), and deleting the Runemate folder and .jar and giving it a fresh dl, but that did not work either.

    Has anyone else had this problem? And if so, how do I go about resolving this issue?

    Thanks!

     
  2. Best Answer:
    Post #13 by Cloud, May 16, 2015
  3. This is client support, which is for client issues. For bot specific issues please post in the respective bot's thread.
     
  4. I did reply on the script bot specific forum, but since everyone else is able to run the script bot without a hitch, the script bot writer (Eagles13) said it was a client issue, and that Cloud would be able to help.

    He said it might be a client error specific to my gamepack. I deleted runemate and the folder in c drive and redownloaded, but still gives the same error. It works fine on my vps.
    --- Double Post Merged, May 13, 2015, Original Post Date: May 13, 2015 ---
    Now, other scripts bots like a recently released LRC script bot is giving the same error. Am I the only one getting this error? i am clearly logged into RS. Is it something related to my graphic settings?
     
  5. It start happening to all Eagles scripts bots after the latest rs update, I havent been able to run his fletcher ever since.
     
  6. @Cloud Could this be a gamepack-related thing? I've tested the relevant bots, and they work fine.
     
  7. I am also getting wierd errors like the one below, that no one else seems to be getting with the same scripts bots. Other people can run those scripts bots without a hitch. Also, I can run the same script bot, without a problem on my vps. But for some reason, when i run it on my laptop, it throws this error.

    java.lang.NullPointerException
    at app.WN.for(kxb:83)
    at com.runemate.game.api.hybrid.region.GameObjects.getLoaded(bzb:213)
    at com.runemate.game.api.hybrid.region.Banks.getLoadedBankBooths(agc:239)
    at com.runemate.game.api.hybrid.region.Banks.getLoaded(agc:251)
    at com.alpha.api.Bank.getNearest(Bank.java:107)
    at com.alpha.api.Bank.isPresent(Bank.java:135)
    at com.alpha.api.framework.bot.tasks.generic.BankHandler.validate(BankHandler.java:71)
    at com.alpha.api.framework.bot.AlphaBot$$Lambda$821/850063436.test(Unknown Source)
    at java.util.stream.ReferencePipeline$2$1.accept(Unknown Source)
    at java.util.LinkedList$LLSpliterator.tryAdvance(Unknown Source)
    at java.util.stream.ReferencePipeline.forEachWithCancel(Unknown Source)
    at java.util.stream.AbstractPipeline.copyIntoWithCancel(Unknown Source)
    at java.util.stream.AbstractPipeline.copyInto(Unknown Source)
    at java.util.stream.AbstractPipeline.wrapAndCopyInto(Unknown Source)
    at java.util.stream.FindOps$FindOp.evaluateSequential(Unknown Source)
    at java.util.stream.AbstractPipeline.evaluate(Unknown Source)
    at java.util.stream.ReferencePipeline.findFirst(Unknown Source)
    at com.alpha.api.framework.bot.AlphaBot.onLoop(AlphaBot.java:103)
    at com.runemate.game.api.script bot.framework.LoopingScript.run(brb:38)
    at com.runemate.game.api.script bot.framework.AbstractScript.start(fqb:54)
    at app.Nm.run(hnb:127)
     
  8. What is your gamepack id?
     
  9. Not exactly sure, what that is, or how to find it.
    --- Double Post Merged, May 14, 2015, Original Post Date: May 14, 2015 ---
    is it this?
    [​IMG]
     
  10. Yes it is. @Cloud
     
  11. could someone please help with this? Cant run a majority of the scripts bots. All of them keep erroring out.
     
  12. @Cloud will look at it at his earliest opportunity I'm sure.
     
  13. Could you give us an explanation or atleast your thought why its happening to just a few of us? Seems like majority of the community can run bots without errors, I havent been able to run a single one since the update
     
  14. Try now.
     
  15. Thanks! Seems to work now! :D
     
  16. Seems to be running pretty well now yes, thanks a lot!
     

Share This Page

Loading...