Resolved Problem with my local scripts.

Discussion in 'Developer Support' started by ZombiePie, Oct 12, 2016.

  1. Hey :)

    I have been trying to follow the instructions by Eagles13, It seems the video is outdated but still it did help me understand the basics of how to write the code.

    Since I know somewhat basic C++, I have been spending time reading all the tutorials out here.

    While going through the basics, I noticed that there is no "com.runemate.Boot". It seems it has been replaced by "com.runemate.boot.Boot".
    And then I fixed the "Program arguments" as per the tutorial. "-sdk -login:[username]:[password]:RS3"

    Everything else is same as shown in the video by Eagles13.

    The problem starts when i try to test out my code. I get the following errors.

    Code (Text):
    1. Invalid login syntax.
    2. [Debug] RuneMate Version: 2.3.5
    3. [Debug] Java Version: 8u101 x86 (Oracle Corporation)
    4. [Debug] Operating System: Windows 10 x64
    5. Oct 12, 2016 12:41:15 PM java.util.prefs.WindowsPreferences <init>
    6. WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.

    1) What is this Invalid login syntax.
    2) Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002.
    3) Also I can't seem to run/find my local code.

    Please help.
    #1 ZombiePie, Oct 12, 2016
    Last edited: Oct 12, 2016
  2. Best Answer:
    Post #2 by Aidden, Oct 12, 2016
  3. It's not an issue to worry about, afaik it happens to most people and can be ignored. The reason you can't find your local bots is because you need to go into spectres settings and change the local bot directory to your projects out folder.
    Also, Welcome to RuneMate. Hope you like what you see and decide to stick around :p
    ZombiePie and auxi like this.
  4. Thanks for your speedy reply Aidden :)

    I found how to set the directory successfully :D
    It seems I need to run spectre through Intellij to view the developer settings.

    And yup, RuneMate seems to be fun. xD
  5. Not a problem. Na you don't need to run it through intellij, you can run it through a batch file with the command you mentioned.

Share This Page