Resolved [RS3] All scripts stopping as soon as they start

Discussion in 'Client & Site Support' started by Furor, Jul 7, 2014.

  1. @Cloud
    I'm having a major problem where all scripts bots are stopping immediately after they start and before the GUI of each individual script bot is able to pop up. I'm running Java 7 Update 55 (Java 7 Update 60 has a crash when using directx and a blank screen with opengl, log file here: http://pastebin.com/a7tAYzc5)

    The scripts bots I've tested and had this happen on are: Omega AIO Cooker, Aidden's Woodcutter, Aidden's area builder, & Omega AIO tanner, aka all scripts bots I've been able to test. The logs don't help much either with the problem: http://pastebin.com/vP0BG54L
     
  2. Hmm, so you're running these scripts bots off the bot store then right?
     
  3. Yup.
     
  4. Does this only happen for RS3 or is it OSRS as well? I'm running 7 update 40
     
  5. Haven't been able to test OSRS, F2P atm, tried running it with Java 7 update 40 so it doesn't seem to be java version.
     
  6. Make a new account and you can use osrs on the last 6 worlds for i think its 14 days? Try that and see how it goes
     
  7. Same result on OSRS, using your tutorial island solver.

    Edit: Log: http://pastebin.com/qv73JMnk
     
  8. @Cloud i just tested both my Tutorial solver and my woodcutter via sdn scripts bots and i'm not experiencing this problem.
     
  9. I'm not really sure what to make of this, I can't reproduce it either... is there anyway you could make a video and upload it?
     
  10. Sure, no problem.
     
  11. Video is up:
     
  12. Hmm, since the UI's aren't popping up, i think it could be a security issue on your side, where GUI's are not allowed to pop up vis a vis a third party program. Just my $0.02
     
  13. That's really weird ...
    My tutorial solver doesn't have a gui so its not that :/
     
  14. Oww ok :/
     
  15. And the GUI usually pops up anyways after the script bot has stopped on scripts bots that do have GUIs
     
  16. I'm really feeling something towards your Java, I understand you have the latest version, but if I could tinker with your settings and whatnot. :confused:
     
  17. Make sure you are running with the JRE and not the JDK.
     
  18. Possibly found the problem. I ran the jar via batch and was given this warning:

    Code (Text):
    1. Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
    Attempting to fix now and see if it changes anything.

    Edit: It appears to be an error related to Groovy or something, looking at a fix now.
    Edit2: Fixed the warning via http://stackoverflow.com/questions/...warning-could-not-open-create-prefs-root-node
    Edit3: Fix did nothing in terms of running scripts bots, looking at other possibilities atm.

    Edit4: I'm running it via this batch script bot
    Code (Text):
    1. "C:\Program Files\Java\jre7\bin\Java.exe" -jar RuneMate.jar
    2. pause
    So it couldn't possibly be running via JDK
     
    #18 Furor, Jul 8, 2014
    Last edited: Jul 8, 2014
  19. I guess the only other thing you can try right now is to see if it happens for all scripts bots. Also, which antivirus are you running?
     
  20. My brain
     
    Arbiter likes this.

Share This Page

Loading...