Resolved RS3 Crashing

Discussion in 'Client & Site Support' started by Aidden, Aug 26, 2014.

  1. RS3 seems to be crashing for me quite consistently, i can't even run a script bot. But when i run in dev mode it doesn't seem to be crashing at all.
    @Cloud @Arbiter
     
  2. Doesn't happen to me, are you sure you're using the right JRE/JDK/whatever?
     
  3. This doesnt happen to me either.
     
  4. Lol Yeah its really weird. I run it without batch and you can see lag in the mouse straight away. Usually ill get to log in and that's as far as I get before it crashes. But then when I run with a batch file to run in sdk I don't see lag and can log in and play
     
  5. I don't think it happens with osrs but I haven't checked to make sure
     
  6. How many java prosesses do you run when trying to use the bot?

    how much memory is used
     
  7. Make sure you are NOT running with JDK.
     
  8. Only one. And around 230mb and jumps to 400mb I think :/
    Ill make sure soon as this episode of true blood finishes :p
    Edit: So i'm pretty sure it was running in JDK. If i run it using a bat file without the sdk command it doesn't seem to happen and the process changes from javaw.exe to java.exe however, JDK seems to always be between 200 and 400mb whereas sdk started around 600mb and has now risen to 1gb. Does that help isolate the leak at all? I've noticed that in jdk the red berry picker status was always null but with sdk it actually works so jdk mustn't be letting some things get called or whatever.

    @Cloud @Arbiter sorry if that doesn't make much sense lol.
     
    #8 Aidden, Aug 26, 2014
    Last edited: Aug 26, 2014

Share This Page

Loading...