Resolved [RS3, EoC] Not interacting with Inventory Items

Discussion in 'Client & Site Support' started by SlashnHax, Dec 17, 2014.

  1. SlashnHax

    SlashnHax The Chosen One

    Joined:
    Dec 10, 2014
    Messages:
    2,879
    Likes Received:
    820
    Posting on behalf of a friend, but I've seen the bug first hand.

    EoC, bot withdraws everything fine, is aware that the correct items are in the inventory, but when it tries to interact it moves the mouse to about the middle of the inventory and doesn't do anything.

    Legacy, bot works fine.

    The interaction with the SpriteObjects seems to be the only part where it fails, banking, casting spells etc. all work fine.
     
  2. Baddest Man on Earth

    Joined:
    Nov 26, 2014
    Messages:
    610
    Likes Received:
    242
  3. SlashnHax

    SlashnHax The Chosen One

    Joined:
    Dec 10, 2014
    Messages:
    2,879
    Likes Received:
    820
    Works fine on my local version, and they showed the same problem using several other scripts bots as well so I doubt it's a source problem.

    My code is the generic get item by ID, check for null, interact.
     
  4. alkimista

    Joined:
    Dec 11, 2014
    Messages:
    348
    Likes Received:
    17
  5. Cloud

    Cloud The Developer

    Joined:
    Jul 28, 2013
    Messages:
    2,327
    Likes Received:
    755
    Hmm, I created a fresh account on EOC, collected bones and then checked into it and I wasn't able to reproduce the issue unfortunately. Is there any more information you can provide?

    Does this only happen in the bank?
     
  6. alkimista

    Joined:
    Dec 11, 2014
    Messages:
    348
    Likes Received:
    17
    if u want i can give u the access to one of my server and accounts with teamviewer to show u what happen
     
  7. Cloud

    Cloud The Developer

    Joined:
    Jul 28, 2013
    Messages:
    2,327
    Likes Received:
    755
    Sure that would help.
     
  8. alkimista

    Joined:
    Dec 11, 2014
    Messages:
    348
    Likes Received:
    17
    any update on that?
     
  9. Aidden

    Aidden The better executive ;)

    Joined:
    Dec 3, 2013
    Messages:
    3,282
    Likes Received:
    664
    @Cloud
     
  10. Cloud

    Cloud The Developer

    Joined:
    Jul 28, 2013
    Messages:
    2,327
    Likes Received:
    755
    The issue has been identified. The problem is the item is not being considered visible. Unfortunately I haven't found the exact cause of the issue, but if you let me do a follow up with a testing build I may be able to find the cause and fix it.
     
  11. alkimista

    Joined:
    Dec 11, 2014
    Messages:
    348
    Likes Received:
    17
    u know that if u need one of my accounts to test it is not a problem
     

Share This Page

Loading...