Bug RSClient not being recognised

Discussion in 'Client & Site Support' started by wolfskull, May 8, 2016.

  1. Hey guys, I'm having trouble getting runemate to detect the game clients.

    Both osrs and rs3 (java) clients are installed and start up fine when run manually, but runemate can't detect the processes, it is being run as admin as well.

    Java 8u92, Win 7

    Any ideas? Thanks
     
  2. Is there anything odd in your RuneMate logs, found in %userprofile%/RuneMate/logs ?
     
  3. Nope, all the logs are just variations of
    Code (Text):
    1. [Debug] RuneMate Version: 2.1.3
    2. [Debug] Java Version: 8u92 x86 (Oracle Corporation)
    3. [Debug] Operating System: Windows 7 x64
    4. Attempting to start official client. If it does not open shortly please do so manually.
    5. Checking for a new game instance every second for two minutes or until one is found.
    Edit:
    I've realised that if I run RuneMate through intelliJ, it isn't even able to start the rs clients. (running the jar itself using the same args, runemate can open the clients)
    But either way, runemate still doesn't detect the clients even when it does open them itself

    Final edit:
    The issue was with my win-user not having elevated privileges and running runemate as administrator wasn't letting it do what it needed to for some reason. Fixed by changing my user to admin and then running runemate as admin.
     
    #3 wolfskull, May 8, 2016
    Last edited: May 9, 2016

Share This Page

Loading...