RuneMate Beta 14 - Bug Reports

Discussion in 'Client & Site Support' started by Viewer, Apr 19, 2014.

Thread Status:
Not open for further replies.
  1. You know how it works ...post your bugs here ;)
     
  2. Keyboard.type(); never returns true for me. I assumed it would return true if it successfully entered a string but nothing lol.
     
  3. Does it successfully enter the entire string? Also are you passing true or false for the second argument (pressEnter)
     
  4. Don't know if this kind of things belong in this thread but since today, I can't start the bot anymore.
    This is the output log:

    apr 20, 2014 2:23:37 PM java.util.prefs.WindowsPreferences <init>
    WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.

    I guess this isn't any relevant information but this is what I got.
     
  5. That error log simply means it failed to write to the registry, it's an issue with Java and Windows 8 and not related to the client itself.
     
  6. Oh I'm on W7, found out it was a registry error and fixed it.
    Still, the won't run while it actually did yesterday.
     
  7. It successfully enters the string, and I'm running true as the second argument
     
  8. Does it also successfully press enter?
     
  9. I didn't realize it could also happen on windows 7, interesting. Also, is it starting up at all? There haven't been any updates in the last couple days.
     
  10. Well that's the main problem at the moment. It's not starting up. I tried clearing the RuneMate cache but that didn't solve any problem really.
    There is no output that indicates it crashed or whatsoever.
    And about the registry, I fixed the error by just adding the key to the registry. I'm not sure if that's gonna work since it's empty.
     
  11. So not even the login screen appears?
     
  12. Nope, it remains as a dead javaw.exe with no window popping up.
     
  13. yes it does.
     
  14. Fixed in the next release, typing the enter key was always returning false so the type(String) method thought it was failing to be typed.
     
  15. Players.getLocal().getHealthGauge() != null
    Also returns true in OSRS while out of combat.
     
  16. Inventory.contains methods don't work when the equipment stats interface is open.

    Edit- it appears that it may be all inventory methods not just contains
     
  17. I assume you're talking about RS3, what does Inventory.getItems() return when the equipment stats interface is open.
     
  18. Nope, OSRS
     
Thread Status:
Not open for further replies.

Share This Page

Loading...