Resolved RuneMate Linux Not Working

Discussion in 'Client & Site Support' started by Hurricane, Oct 31, 2015.

  1. So after installing RuneMate on my Ubuntu 14.04.3 LTS copy via the Install script bot found at Download | RuneMate, I get to the first login screen and can input my Username, Password and Select the Game but after that the Client seems to dissappear and a RuneMate Icon appears at the top in my taskbar but the client never seems to load. What's going on?

     
  2. Best Answer:
    Post #11 by Arbiter, Nov 3, 2015
  3. Have you installed the video drivers correctly on Ubuntu?
     
  4. Hmm, no. How would I do that?
     
  5. [1222UTC] I'm booting up a VM right now with Ubuntu 14.04 to see if i can replicate your issue.

    [1903UTC] @Hurricane I got pulled away for other things but I finally looked into the issue. It looks as though the application is attempting to write system preferences within the /etc directory which is not normally allowed by a non-root user. I'm looking for a temp workaround now, but don't get your hopes up because I can't even say for sure if the is the issue here. *EDIT: It didn't work, see post #6 below.
    Code (Text):
    1. Nov 01, 2015 17:09:24 AM java.util.prefs.FileSystemPreferences syncWorld
    2. WARNING: Couldn't flush system prefs: java.util.prefs.BackingStoreException: /etc/.java/.systemPrefs/com create failed.
     
    #4 Plebsin, Nov 1, 2015
    Last edited: Nov 2, 2015
  6. If all else fails, you can always test with the standalone version to make sure the issue is not in the installation process.
     
  7. Oh yeah, I forgot to mention that the standalone does work.

    And before I forget, one last thing I tried with the installed client was to override the persistence preferences to point at a user-writable directory
    "-Djava.util.prefs.userRoot=/home/testuser/test-004" and "
    "-Djava.util.prefs.systemRoot=/home/testuser/test-004" in the runemate.vmoptions file. This did fix the errors showing up in the log, which was double-checked by looking at the running jvm options using the jps utility, but this did not fix the issue of the client not coming up after login.
     
  8. What do you mean by not coming up? Perhaps a screenshot would help.
     
  9. It sounds like the native installers are making it write to a different backing store file than usual (on windows it uses the registry).
     
  10. If you installed RuneMate into a directory that requires super user, then you're probably going to need to use sudo to run it. Alternatively, you can install it somewhere local like /home/you/runemate/.
     
  11. Gfycat GIF

    Exactly. The installer defaults the backing store to the system root node, which on linux is "/etc". *EDIT: Arbiter and I were toying around on Slack and noticed that it will run using sudo.

    I installed it under the user's home directory.
     
    #10 Plebsin, Nov 3, 2015
    Last edited: Nov 3, 2015
  12. Related issue: Resolved - [LINUX] How to get started? | Community | RuneMate

     

Share This Page

Loading...