Resolved Runemate on Centos

Discussion in 'Client & Site Support' started by Prodigy, Jun 26, 2015.

  1. [​IMG]

    says syncing with runemate,then just blanks out like this :(

     
  2. Best Answer:
    Post #18 by Cloud, Jun 30, 2015
  3. Run it through Terminal using "java -jar RuneMate.jar" and tell us if there is any error.
     
  4. ok, will try it
    --- Double Post Merged, Jun 26, 2015, Original Post Date: Jun 26, 2015 ---
    dunno if im doing something wrong here, but nothing happens when i type in this

    [​IMG]
     
  5. Open a fresh Terminal and navigate to the directory that has the jar first with "cd /dir/to/jar/".
     
  6. Here you go

    [​IMG]
     
  7. @Cloud pretty sure I added code to disable transparency for Linux. It's probably not catching all the cases. Can you look into this or at least work with me to resolve it?
     
  8. After a quick review I'd say that it's most likely being called because we have to give the overlay canvas a background with a transparency of 1 out of 255. This if it wasn't transparent then you wouldn't be able to see the game and a value of at least 1 is required so that we can receive mouse events on every pixel instead of just pixels that had paint drawn on it. If that's the case, we'd have to disable the canvas overlay when we detect this to fix it.

    Edit: But if we did disable the overlay completely, first of all there obviously wouldn't be able to be a paint, and second of all we wouldn't be able to intercept and redirect Mouse, Keyboard, and Focus events to bots that implement the listeners.
     
    #7 Cloud, Jun 26, 2015
    Last edited: Jun 27, 2015
  9. Any fix possible for this?
     
  10. Code (Text):
    1.  
    2. [root@****** Downloads]# java -jar RuneMate.jar
    3. (05:09:28) [Debug] Started RuneMate v1.1.0 (preview) with Java 8 Update 45
    4. (05:09:40) [Setup] Downloading game...
    5. (05:09:42) [Setup] Syncing with RuneMate Cloud (8473db4a)...
    6. #
    7. # A fatal error has been detected by the Java Runtime Environment:
    8. #
    9. #  SIGSEGV (0xb) at pc=0x00007f65ac36450d, pid=30611, tid=140074966066944
    10. #
    11. # JRE version: Java(TM) SE Runtime Environment (8.0_45-b14) (build 1.8.0_45-b14)
    12. # Java VM: Java HotSpot(TM) 64-Bit Server VM (25.45-b02 mixed mode linux-amd64 compressed oops)
    13. # Problematic frame:
    14. # C  [libjaggl.so+0x850d]  Java_jaggl_OpenGL_init+0x9d
    15. #
    16. # Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
    17. #
    18. # An error report file with more information is saved as:
    19. # /root/Downloads/hs_err_pid30611.log
    20. #
    21. # If you would like to submit a bug report, please visit:
    22. #   http://bugreport.java.com/bugreport/crash.jsp
    23. # The crash happened outside the Java Virtual Machine in native code.
    24. # See problematic frame for where to report the bug.
    25. #
    26. Aborted
    27.  
    When I try to load on centos 7, it gets to the forced First time playing run auto setup screen. Clicking that will crash for error
     
  11. Use a better distro or a more recent version of CentOS (if applicable) @Prodigy.
    --- Double Post Merged, Jun 29, 2015, Original Post Date: Jun 29, 2015 ---
    This was supposed to be fixed a while back. @Cloud any idea why this is back?
     
  12. So basically, paint the game onto the overlay without transparency.
     
  13. transparency error on centos 6 / ubuntu 12, (been testing a few distributions)
     
  14. i never had this with RSBot back in the past :O how is this possible with runemate?
     
  15. Because I didn't want to disable OpenGl globally on all Linux distros and I was hoping there would be a way to detect it and disable it selectively.
     
  16. Tested with latest version of Ubuntu. same translucency error. Not sure about CentOS 7 though.
     
  17. centos 7 gets the opengl error
     
  18. I vote to implement OpenGL block globally for Linux distros until we have the time to further analyze since the two main distros that many others spin off from exhibit the same issue.
     
  19. Done for the next release.
     
  20. @Cloud, can you also disable mouse trails on linux?
    It seems the transparency being disabled messes with it fading out:
    [​IMG]
    --- Double Post Merged, Jun 30, 2015, Original Post Date: Jun 30, 2015 ---
    Also, there is a problem where it is improperly using quotes in the filename:
    Code (Text):
    1. Populating /home/john2/RuneMate/"/home/john2/RuneMate/RuneMate.jar".
    and there is a folder being made called ".
    [​IMG]
     
  21. @TheBat the first issue is unrelated to transparency and is a known bug. It's complicated and if you would be interested in working with us on it (for a bounty) hit me up on Skype. Regarding the second bug we are very interested in reproducing that. Please start a new thread and tag @Cloud. Marking this issue as resolved.
     

Share This Page

Loading...