Question Runemate on Linux?

Discussion in 'Client & Site Support' started by nrkoo, Oct 13, 2015.

  1. Hi all!

    I'm running Debian on my laptop, and I can't seem to start up the RuneMate client. Trying to start it up with java -jar RuneMate.jar gives me the following errors:

    ~/Downloads$ java -jar RuneMate.jar
    Exception in thread "main" java.lang.UnsupportedClassVersionError: com/runemate/Boot : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
    at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
    at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)


    Has anyone managed to run RuneMate on Linux?
     
  2. I think your best chances are running it on Linux Mint or Ubuntu, as there are so many different distributions it is hard to keep maintaining the bot in all of them, but I believe most of them will work fine someday. @Arbiter what do you think?
     
  3. My friend (hes haxor) said that Ubuntu = Debian + canonical shit.
     
  4. By the way, what is your current java version?
     
  5. java -version
    java version "1.7.0_79"
    OpenJDK Runtime Environment (IcedTea 2.5.6) (7u79-2.5.6-1~deb8u1)
    OpenJDK 64-Bit Server VM (build 24.79-b02, mixed mode)
     
  6. Remove OpenJDK completely and install Oracle's Java most recent version, then try running RuneMate again.
     
  7. Use 1.8 jre instead than 1.7.. Runemate will not work with 1.7 in linux. I am using linux lite.
     
  8. Awwwww yissssssss!

    https://wiki.debian.org/JavaPackage <- Followed this guide to install Java 8, RuneMate started working. Will return with possible problems.
     

Share This Page

Loading...