Resolved RuntimeException & NoSuchMethodError

Discussion in 'Developer Support' started by ghoi, Jun 1, 2016.

  1. Hi all,

    I'm setting up my environment to start developing. I'm on a mac (if that helps). I've tried to follow Party's beginner guide, so I have my hello world bot, but after compiling and running, I immediately get this:

    Code (Text):
    1. Exception in Application start method
    2. Exception in thread "main" java.lang.RuntimeException: Exception in Application start method
    3.     at com.sun.javafx.application.LauncherImpl.launchApplication1(
    4.     at com.sun.javafx.application.LauncherImpl.lambda$launchApplication$156(
    5.     at
    6. Caused by: java.lang.NoSuchMethodError: sun.jvmstat.perfdata.monitor.protocol.local.LocalEventTimer.try(Ljava/lang/String;)Ljava/lang/String;
    7.     at nul.IiiIIIiIIiIi.try(cob:202)
    8.     at nul.IIiiiIiIIIII.try(xwb:20)
    9.     at nul.IIiiiIiIIIII.super(xwb:183)
    10.     at nul.IiIIIIiiiIiI.try(sub:157)
    11.     at com.runemate.boot.Boot.try(ihc:273)
    12.     at java.util.Arrays$ArrayList.forEach(
    13.     at com.runemate.boot.Boot.start(ihc:94)
    14.     at com.sun.javafx.application.LauncherImpl.lambda$launchApplication1$163(
    15.     at com.sun.javafx.application.PlatformImpl.lambda$runAndWait$176(
    16.     at com.sun.javafx.application.PlatformImpl.lambda$null$174(
    17.     at Method)
    18.     at com.sun.javafx.application.PlatformImpl.lambda$runLater$175(
    19.     at$
    20. java.lang.NoSuchMethodError: sun.jvmstat.perfdata.monitor.AbstractPerfDataBufferPrologue.try(Ljava/lang/String;)Ljava/lang/String;
    21.     at nul.iiiiIIiiiiiI.<clinit>(jqb:1)
    22.     at
    23. An unhandled error occurred while shutting down.
    I've also tried to run SlashnHax's open source miner, and I get the same error.

    Potential problems:
    - I'm not sure if I picked the right JRE in my configurations. Couldn't find a mac 32 bit JRE (macs are only 64bit I think?) and couldn't find it in the Runemate directory, so I tried all of these options and it didn't work (pic attached)

    Thanks for any help!!


    Attached Files:

  2. Best Answer:
    Post #3 by Arbiter, Jun 1, 2016
  3. #2 Serene, Jun 1, 2016
    Last edited: Jun 1, 2016
  4. You're going to want the JDK for development purposes. If you use the JDK and you're still having issues, RuneMate auto-downloads the right JRE it needs to run. It's inside /Applications/ I forget the exact path but you should be able to find it easily. If you have trouble someone in the Dev Chat can likely Teamviewer you and help you. Sorry for the difficulty you're having. Apple doesn't like Java very much and doesn't make it easy.
  5. Thanks guys I got it! Just had the wrong folder selected before ugh. The path on my computer was


    if anyone else has this problem also

Share This Page