Resolved Spectre crash, Scripts won't execute, 300MB log file.

Discussion in 'Developer Support' started by DevTucker, May 27, 2016.

  1. Well, about five minutes ago Spectre started acting quite strange. When I tried to start scripts bots I would get Java heap memory errors. The first time or two it would point to some classes named like.. "IllILILILLLILILI" (Not exact) but after the first two times it didn't even provide a stack trace. Just "Java heap error"

    I have almost 5 million lines in my log, all inputted over the last few minutes spamming this error:

    Code (Text):
    1. java.lang.ArrayIndexOutOfBoundsException: -1
    2.     at java.util.ArrayList.elementData(
    3.     at java.util.ArrayList.get(
    4.     at com.sun.javafx.collections.ObservableListWrapper.get(
    5.     at com.sun.javafx.collections.VetoableListDecorator.get(
    6.     at javafx.scene.Parent.updateCachedBounds(
    7.     at javafx.scene.Parent.recomputeBounds(
    8.     at javafx.scene.Parent.impl_computeGeomBounds(
    9.     at javafx.scene.layout.Region.impl_computeGeomBounds(
    10.     at javafx.scene.Node.updateGeomBounds(
    11.     at javafx.scene.Node.getGeomBounds(
    12.     at javafx.scene.Node.getLocalBounds(
    13.     at javafx.scene.Node.updateTxBounds(
    14.     at javafx.scene.Node.getTransformedBounds(
    15.     at javafx.scene.Node.updateBounds(
    16.     at javafx.scene.Parent.updateBounds(
    17.     at javafx.scene.Parent.updateBounds(
    18.     at javafx.scene.Scene$ScenePulseListener.pulse(
    19.     at$runPulse$30(
    20.     at Method)
    21.     at
    22.     at
    23.     at
    24.     at
    25.     at$runToolkit$404(
    26.     at$
    27.     at Method)
    28.     at$null$148(
    29.     at

    I've carefully observed all of the class names here and none of them have anything to do with my local scripts bots. (Running in -SDK mode). I haven't modified my scripts bots any to make something like this occur. I simply was restarting a script bot because I reached my 3-hour test period.

    It may or may not be a bug related to spectre directly, but I figured I'd post it here anyway.
    --- Double Post Merged, May 27, 2016, Original Post Date: May 27, 2016 ---
    Found the stack-trace of the heap error in my logs:

    Code (Text):
    1. java.lang.OutOfMemoryError: Java heap space
    2.     at java.util.HashMap.newNode(
    3.     at java.util.HashMap.putVal(
    4.     at java.util.HashMap.put(
    5.     at nul.iiIiiIiiIiiI.try(wob:31)
    6.     at nul.iiiiiIiiiIiI.try(dtb:206)
    7.     at nul.iiiiiIiiiIiI.try(dtb:61)
    8.     at nul.IIIiIIiIiIii.try(dtb:11)
    9.     at nul.IIIiIIiiIiiI.try(wwb:263)
    10.     at nul.iiIiIIiIIIiI.try(wnb:75)
    11.     at nul.IIIiIIiiIiiI.try(wwb:30)
    12.     at nul.iiIIIIiiiiII.try(nwb:92)
    13.     at nul.IiIiIIiiIIii.try(uqb:92)
    14.     at
    15.     at nul.IIIiIIiiIIIi.getContainedItem(frb:153)
    16.     at
    17.     at
    18.     at
    19.     at$Slot.getComponent(nyb:5)
    20.     at com.devtucker.bots.spectrefarmer.SpectreFarmerScript.onStart(
    21.     at com.devtucker.framework.rewrite.AdvancedScript.onStart(
    22.     at
    23.     at
    --- Double Post Merged, May 27, 2016 ---
    Since the error indicates QueryBuilder was involved, here is my QueryBuilder code:

    Code (Text):
    1. Equipment.newQuery().ids(FIRE_STAFF_ID).results().first()
  2. Best Answer:
    Post #2 by Arbiter, May 28, 2016
  3. Are you using JavaFX in your local bot? If so, the issue is likely in your bot. When you dispatch a Runnable to the JFX Platform using something like Platform.runLater you lose the stack traceability, thus your own classes not being included in the top stack trace. You should investigate your UI code thoroughly. The java heap space exception is not an issue. The specific stack that encounters that exception is not necessarily the problem; it just means that it couldn't do what it wanted to do because it ran out of RAM when it tried to allocate something it needed. Fixing the first issue will likely fix the latter.
    DevTucker likes this.
  4. Thanks for the information on JavaFX loosing the stack, I had no idea that happened. I'm not sure what the problem was, but I would assume that some bin files got corrupted, as once I ran a clean+rebuild on the project everything seemed to fix itself. Thanks for the response.

Share This Page