Resolved (Ubuntu) Multiple Things

Discussion in 'Client & Site Support' started by Philosobyte, Jan 31, 2015.

  1. All of these bugs are with Safe mode.

    Bug #1 - Persistent Mouse Trail
    The mouse trails accumulate and leave white on the game screen, eventually able to cover the entire screen.

    Bug #2 - Overlay
    The dark, half-opaque overlay is a separate window. It slowly darkens the game window to this amount of opacity when left unmaximized, and does not get more opaque.
    [​IMG]
    -----------------------------------------------------------------
    When the game window is maximized, the overlay does not budge, but the click area stays in that overlay. This means that when you click on the left bottom edge of the overlay, you are clicking on the corresponding left bottom edge on the gamescreen. Also, this is on the resizable graphics setting (it's not resizing).
    [​IMG]
    ---------------------------------------------------------------------

    The overlay can be dragged and resized around the edges. I first discovered this when I dragged the client to the top of the screen, the actual client didn't move further, and the overlay moved further.
    [​IMG]

    The opacity can be dragged off, but the mouse is not visible on the game window anymore. Notice "Overlay Canvas" on the left. I also noticed that clicking on the game screen itself (not the overlay) still worked - clicking on the canvas also clicked a corresponding point on the game screen.
    [​IMG]

    Bug #3 - Model loading
    Also happened with a couple other IDs, if I remember correctly, 40643 and 40655. I might be wrong.
    [​IMG]

    Bug #4 - OpenGL
    Safe mode was entered manually for the above bugs by spamming "S" when the client window popped up. When the client is started and you don't spam S, you're forced to auto-setup. And the moment you click that button, it switches to OpenGL, giving this error. (Note that RuneScape in FireFox worked well in OpenGL)

    #
    # A fatal error has been detected by the Java Runtime Environment:
    #
    # SIGSEGV (0xb) at pc=0x00007fd4162f150d, pid=27900, tid=140549090215680
    #
    # JRE version: Java(TM) SE Runtime Environment (8.0_31-b13) (build 1.8.0_31-b13)
    # Java VM: Java HotSpot(TM) 64-Bit Server VM (25.31-b07 mixed mode linux-amd64 compressed oops)
    # Problematic frame:
    # C [libjaggl.so+0x850d] Java_jaggl_OpenGL_init+0x9d
    #
    # Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
    #
    # An error report file with more information is saved as:
    # /home/raymondbl/IdeaProjects/RuneMate/hs_err_pid27900.log
    #
    # If you would like to submit a bug report, please visit:
    # http://bugreport.java.com/bugreport/crash.jsp
    # The crash happened outside the Java Virtual Machine in native code.
    # See problematic frame for where to report the bug.
    #
    Aborted (core dumped)

    Here is the log:
    https://gist.github.com/anonymous/6f5df8e596dadb3088cd


    When the client is opened again after entering in ulimit -c unlimited, something similar comes up.
    https://gist.github.com/anonymous/0ab3035f7e5a90a1805f
     
    Arbiter likes this.
  2. @Arbiter @Cloud

    Edit:
    [​IMG]

    I just re-tested and confirmed that the browser (FireFox) version of RuneScape works exceedingly well with OpenGL.
     
    #2 Philosobyte, Jan 31, 2015
    Last edited: Jan 31, 2015
  3. @Cloud Nice in-depth bug report here.
     
  4. Thanks for the bug report. I am sure @Cloud will make use of it when he is next available to compatibility test.
     
  5. Any updates on this?
     
  6. I'll put in an effort to improve the way runemate acts on ubuntu before the next release :)
     
  7. Thank you !!
     

Share This Page

Loading...