Question [RESOLVED] Client Cant Find main Class

Discussion in 'Developer Support' started by FalloutR, Mar 10, 2016.

  1. #1 FalloutR, Mar 10, 2016
    Last edited: Mar 10, 2016
  2. You need to enter the mainclass with the package it is contained in, not a path to the actual class file.
    For example: com.example.bots.MainClass
  3. Ran refresh 3 different times modifying the manifest each time attempting to address the "package" the class is in and all it did was alter the directory it was attempting to locate the class in, tried with eclipse's bin also. Imgur: The most awesome images on the Internet
    My theory is because there are compilation errors its not a viable class to be seen, I just did this as a test will get back once i fix my script bot.
    --- Double Post Merged, Mar 11, 2016, Original Post Date: Mar 11, 2016 ---
    Well fixed my compilation errors. Tried verified it was compiled properly by exporting to a jar then extracting, still no luck.
    You would think because its trying to "locate" in the same directory as the class it would work right?
    Imgur: The most awesome images on the Internet
    I've tried everything I can think of and still no luck.
    I'm getting desperate, HELP!
    --- Double Post Merged, Mar 11, 2016 ---
    Resolved with Aidden's help. I was getting the class from an improper build path, and taking only the class doesn't work.

Share This Page