Can not run/(find) script in SDK

Discussion in 'Developer Support' started by BillEEEh, Apr 9, 2015.

  1. Hey there, i'm completely new to the java language, and so far i actually liked following the tutorial and i look forward to knowing java better.

    However, i'm stuck at something i feel is extremely basic, but i think i can't find the problem.

    At the moment i saved a mining script bot i made with the tutorial, but when i select the map i saved it in the RuneMate client cant find it.

    [​IMG]

    If someone could help me, i'd greatly appreciate it!
     
  2. With the client launched in SDK mode, go to bots and choose folder, navigate through your output folders (where the .class are put) in the location you compiled your scripts bots, until the folder visible is the root folder of your package (in your case bMiner), that's how I have it setup.

    Good luck.
     
  3. Thanks for the quick response!
    This however doesn't work. I get this:
    [​IMG]

    However, this is what's in the folder:

    [​IMG]
     
  4. You don't want to be setting it to bMiner inside the src folder, you need to set it to bMiner inside the output folder where the compiled script bot is stored.
     
  5. That would be the bMiner folder in bin right? I pretty much tried every folder but i can't find it
     
  6. Yeah, I have mine set to the folder above my version of your bMiner folder in the bin.
     
  7. Hmm weird then, just in-case, you do use file>save right?
     
  8. You also have to compile the files, just in case you aren't doing that already :)
    Also, have you looked at IntelliJ? I much prefer it over Eclipse
     
  9. As far as i've looked in the settings its compiled, i'll get to intellij before this drives me mad, haha
    --- Double Post Merged, Apr 9, 2015, Original Post Date: Apr 9, 2015 ---
    Hmm. same issue with IntelliJ.. What can the issue be?
     
  10. Have you compiled your project (ctrl + F9 or use the build tab) and then set the directory in the client to the correct folder inside the "out" folder?
     
  11. Yup, it even says that it has been compiled succesfully, i tried every folder possible, the src, out, production, and all folders called bMiner.

    out/production/bMiner/bMiner is the only one with .class files
    and the src folder has the .java file

    I don't know if that helps anything but i don't see what else could be wrong

    [​IMG]
    [​IMG]


    [​IMG]
     
  12. Setting the folder to bMiner/out/production should be fine, I can't see an XML manifest in the images you just posted, do you have one? Also, make sure you are on the same game type as the game type you set in the manifest. (RS3 scripts bots won't show up in OSRS and vice versa)
     
  13. Yes, this is my current setup:

    [​IMG]
     
  14. What does your manifest look like.
     
  15. <manifest> <main-class>com.src.bMiner.bMiner</main-class> <name>bMiner</name> <description>bMiner</description> <version>0.1a</version> <compatibility> <game-type>RS3</game-type> </compatibility> <categories> <category>MINING</category> </categories><!--Required to publish on the bot store--><internal-id>bMiner</internal-id><!--The rest are optional--><hidden>true</hidden> <open-source>true</open-source></manifest>
     

Share This Page

Loading...