Resolved 'could not connect to the server.'

Discussion in 'Client & Site Support' started by Jimy798, Aug 22, 2015.

  1. When I enter my credentials in to the client and click 'sign in', I get an instant response saying 'could not connect to the server.'

    I have disabled my firewall and antivirus, and when I ping in cmd it doesn't pick it up.
    Any solutions would be much appreciated.

  2. Best Answer:
    Post #23 by Arbiter, Sep 1, 2015
  3. Can I get a screenshot of the ping from cmd?
  4. Thanks for your reply. I really want to get this bot working, one of my friends uses it and it looks great. Here is the screenshot. I'm assuming there's something on my computer blocking runemate, but I can't work out what it is.

    EDIT: My cmd is also giving the same result for any website I ping.
    #3 Jimy798, Aug 23, 2015
    Last edited: Aug 23, 2015
  5. try redownloaded java guy had similar problem last night that I helped redownload jdk and java then restart pc, if that doesn't work check your firewall
  6. Thanks for your reply.
    I've updated my JDK and the RuneMate client, and now I'm getting some positive results. It's asking me to update my Java to the 64 bit variant so I'm doing that now. Hopefully it works after this.

    EDIT: Still doesn't work. Just getting the same error as before. Firewall is turned off and I've completely uninstalled my antivirus - still doesn't work.
    #5 Jimy798, Aug 25, 2015
    Last edited: Aug 25, 2015
  7. Still not working. I followed the instruction that you linked.
    I'll attach my DNS settings and what it shows when I try to log on, maybe it will help.
    upload_2015-8-26_15-51-56.png upload_2015-8-26_15-52-12.png upload_2015-8-26_15-52-38.png

    If there's any more information I can give to get this working, let me know.
  8. Did you restart after DNS changes? Also do you have access to a VPN to test with?
    --- Double Post Merged, Aug 26, 2015, Original Post Date: Aug 26, 2015 ---
    Also, who is your ISP? What country are you connecting from? Are you connecting from a work or university network? If so, network firewalls are a real possibility.
  9. I did restart after the DNS changes, and I don't have a VPN to test with unfortunately.

    My ISP is Telstra, I'm connecting from Australia. It's just my home network, and I'm certain there's no network firewalls.

    I don't know if it helps, but I used my personal hotspot on my phone and it still gave the same result.
    #9 Jimy798, Aug 27, 2015
    Last edited: Aug 27, 2015
  10. Hmm i only saw this prob with win xp in the past...
  11. Is your personal hotspot with Telstra too?
  12. No - Optus

    Thanks for all your assistance so far.
  13. Please try using a free VPN. Warning: This is only to debug the problem and you should NOT log in to your RS account using it.
  14. upload_2015-8-29_9-29-38.png

    The VPN worked fine. I'm using it as I write this post - but I still get the same error from RuneMate
  15. What is the output when you run runemate from the command prompt?
  16. upload_2015-8-30_16-39-11.png
  17. That happened because you didn't run it from the correct directory.

    Try java -jar
    and then drag and drop the jar onto the command prompt, it should copy it's full file path.
  18. Sorry about that.
  19. One more time lol, this time add a space after the "-jar" before the file path :p
  20. Hopefully I did it right this time xD
    Sorry for the hassle.


Share This Page