Bug 'Failed to bind to the game client because of a AgentInitializationException'

Discussion in 'Client & Site Support' started by inSaiyan, Sep 20, 2016.

  1. Hi guys, just wanted to make a new thread asking for help.
    I installed RuneMate and Legacy Runescape onto the same drive (M: drive in my case, since RS does not install onto the default C: drive). There are also no Java versions installed besides the one RuneMate automatically installs for me. Any help will be greatly appreciated. I searched through many past threads with no luck. Ask me for any further details.

    [Debug] RuneMate Version: 2.3.5
    [Debug] Java Version: 8u92 x86 (Oracle Corporation)
    [Debug] Operating System: Windows 10 x64
    java.lang.InternalError: instrument library is missing in target VM
    at sun.tools.attach.HotSpotVirtualMachine.loadAgent(cv:52)
    at nul.iIiIiIiiIiII.false(ckb:117)
    at nul.iIiIiIiiIIii.run(amb:168)
    Caused by: com.sun.tools.attach.AgentLoadException: Failed to load agent library
    at sun.tools.attach.WindowsVirtualMachine.execute(hz:16)
    at sun.tools.attach.HotSpotVirtualMachine.loadAgentLibrary(cv:19)
    at sun.tools.attach.HotSpotVirtualMachine.loadAgentLibrary(cv:148)
    at sun.tools.attach.HotSpotVirtualMachine.loadAgent(cv:45)
    ... 2 more

    Attempting to start official client. If it does not open shortly please do so manually.
    Checking for a new game instance every second for two minutes or until one is found.
    Found a new game instance after 3 seconds.
    Failed to bind to the game client because of a AgentInitializationException
    com.sun.tools.attach.AgentInitializationException: Agent JAR loaded but agent failed to initialize
    at sun.tools.attach.HotSpotVirtualMachine.loadAgent(cv:110)
    at nul.iIiIiIiiIiII.false(ckb:117)
    at nul.iIiIiIiiIIii.run(amb:168)
  2. I had this issue before, I reported it before.

    The best thing I did was upgrade to windows 10 fixed everything!
  3. I'm already on Windows 10, my log states so as well ^.^
  4. I believe there are issues when Runescape and Runemate are not installed on the same drive or partition.

    I would recommend you uninstall Runescape and re-install it on the same partition as Runemate. You should be able to choose the installation path during the install process.
  5. Yep I have them both installed on the same drive, like I said in my original post. The Legacy RS installer does NOT let me choose which drive to install to, it just automatically chooses my HDD (Drive:M), so I also install RuneMate to Drive:M.
  6. oh well goodluck

Share This Page