Resolved Flicker "Reviews" section on a bot page

Discussion in 'Developer Support' started by Exia, Feb 9, 2016.

  1. Using os x, the Reviews section flickers a crap ton and is printing this exception:
    Code (Text):
    1. Exception in thread "JavaFX Application Thread" netscape.javascript.JSException: TypeError: null is not an object (evaluating 'document.getElementById('root').offsetHeight')
    2. at com.sun.webkit.dom.JSObject.fwkMakeException(
    3. at com.sun.webkit.WebPage.twkExecuteScript(Native Method)
    4. at com.sun.webkit.WebPage.executeScript(
    5. at javafx.scene.web.WebEngine.executeScript(
    6. at nul.iIIIIIiiIIii.class(trb:199)
    7. at com.sun.javafx.application.PlatformImpl.lambda$null$174(
    8. at Method)
    9. at com.sun.javafx.application.PlatformImpl.lambda$runLater$175(
    10. at$

  2. Best Answer:
    Post #6 by Arbiter, Apr 6, 2016
  3. Wtf is wrong with the Netscape Javascript engine? That code is very basic... I'll test on my Mac shortly. Good find.
  4. This looks like the same issue that was happening in the old client with the flickering canvas. I think it was printing the same message, I just assumed you guys knew about it.
  5. Nah it's not the same message or the same error. This has to do with some WebView hackery I had to do to get the sizing right. I might have to fork the OSX logic. Worst case scenario I may have to just disable it for OSX if the Netscape Javascript engine is just too shitty.
  6. @Arbiter - Don't forget about this one
  7. Self-reminder.
    --- Double Post Merged, Apr 6, 2016, Original Post Date: Apr 6, 2016 ---
    Acknowledged bug, but can't work on it until JVM crash on startup is fixed on OSX @Cloud.
    --- Double Post Merged, Apr 6, 2016 ---
    Managed to disable a bunch of code to prevent the JVM crash and fix the unrelated bug in this thread. Should be resolved in the next build.

Share This Page