Bug Java.io.IOException: Can't run instance or find bots

Discussion in 'Client & Site Support' started by Serene, Apr 19, 2016.

  1. Tried uninstalling and reinstalling, deleting the RuneMate folder and such. Upon fresh install as an admin spectre loads to the new instance screen but it doesn't give me any bots to choose from to start an instance (even though it lists a ton of bots to the left half of the screen under my account). Upon close and re-open (as an admin), the "create instance" button doesn't work at all. Just leaves screen with a green circle spinning.

    Throws Java.io.IOException: "Access denied". Running on 32-bit java, as an admin, on fresh install.

    Logs:
    Code (Text):
    1. [Debug] Version: 2.0.3
    2. [Debug] Operating System: Windows 10 (x64)
    3. [Debug] Java: 8 Update 77 (x86) (Oracle Corporation)
    4. java.io.IOException: Access is denied
    5.     at java.io.WinNTFileSystem.createFileExclusively(Native Method)
    6.     at java.io.File.createNewFile(Unknown Source)
    7.     at nul.IIIIIIiiiiII.new(zmb:81)
    8.     at nul.iIiiiiiIiiii.do(xe:191)
    9.     at nul.iIiiiiiIiiii.do(xe:105)
    10.     at nul.iIiiiiiIiiii.do(xe:223)
    11.     at nul.iiIIiIiIiiiI.<init>(zwb:84)
    12.     at nul.IIIiiIiIIIIi.<init>(hrb:89)
    13.     at nul.IIIiiIiIIIIi.<init>(hrb:24)
    14.     at nul.iiIiiIiiIiII.<init>(htb:96)
    15.     at nul.iiIiiIiiiIII.<init>(htb:96)
    16.     at nul.iiIiiIiiiIII.<init>(htb:225)
    17.     at nul.iIIIiIiIiiiI.do(nqb:138)
    18.     at nul.iIiiIIiiiIII.do(qsb:19778)
    19.     at nul.iIiiIIiiiIII.call(qsb:4769)
    20.     at javafx.concurrent.Task$TaskCallable.call(Unknown Source)
    21.     at java.util.concurrent.FutureTask.run(Unknown Source)
    22.     at java.lang.Thread.run(Unknown Source)
    23. java.security.PrivilegedActionException: java.io.IOException: Access is denied
    24.     at java.security.AccessController.doPrivileged(Native Method)
    25.     at com.sun.javafx.application.PlatformImpl.lambda$runLater$174(Unknown Source)
    26.     at com.sun.glass.ui.InvokeLaterDispatcher$Future.run(Unknown Source)
    27.     at com.sun.glass.ui.win.WinApplication._runLoop(Native Method)
    28.     at com.sun.glass.ui.win.WinApplication.lambda$null$148(Unknown Source)
    29.     at java.lang.Thread.run(Unknown Source)
    30. Caused by: java.io.IOException: Access is denied
    31.     at java.io.WinNTFileSystem.createFileExclusively(Native Method)
    32.     at java.io.File.createNewFile(Unknown Source)
    33.     at nul.IIIIIIiiiiII.new(zmb:81)
    34.     at nul.iIiiiiiIiiii.do(xe:191)
    35.     at nul.iIiiiiiIiiii.do(xe:105)
    36.     at nul.iIiiiiiIiiii.do(xe:223)
    37.     at nul.IiIIiIiIIIIi.<init>(zub:196)
    38.     at nul.iIIiIIiIiiII.do(qsb:12282)
    39.     at java.lang.Iterable.forEach(Unknown Source)
    40.     at nul.iIIiIIiIiiII.new(qsb:13081)
    41.     at com.sun.javafx.application.PlatformImpl.lambda$null$173(Unknown Source)
    42.     ... 6 more
    43.  
    44. java.io.IOException: Access is denied
    45.     at java.io.WinNTFileSystem.createFileExclusively(Native Method)
    46.     at java.io.File.createNewFile(Unknown Source)
    47.     at nul.IIIIIIiiiiII.new(zmb:81)
    48.     at nul.iIiiiiiIiiii.do(xe:191)
    49.     at nul.iIiiiiiIiiii.do(xe:105)
    50.     at nul.iIiiiiiIiiii.do(xe:223)
    51.     at nul.iiIIiIiIiiiI.<init>(zwb:84)
    52.     at nul.IiiIiIiIiiiI.<init>(job:105)
    53.     at nul.IiiIiIiIiiiI.<init>(job:213)
    54.     at nul.IIiiIIiIiiII.<init>(htb)
    55.     at nul.iiIiiIiiiIII.<init>(htb:156)
    56.     at nul.iiIiiIiiiIII.<init>(htb:225)
    57.     at nul.iIIIiIiIiiiI.do(nqb:138)
    58.     at nul.iIiiIIiiiIII.do(qsb:19778)
    59.     at nul.iIiiIIiiiIII.call(qsb:4769)
    60.     at javafx.concurrent.Task$TaskCallable.call(Unknown Source)
    61.     at java.util.concurrent.FutureTask.run(Unknown Source)
    62.     at java.lang.Thread.run(Unknown Source)
    63. Bots refreshed.
    64. java.security.PrivilegedActionException: java.io.IOException: Access is denied
    65.     at java.security.AccessController.doPrivileged(Native Method)
    66.     at com.sun.javafx.application.PlatformImpl.lambda$runLater$174(Unknown Source)
    67.     at com.sun.glass.ui.InvokeLaterDispatcher$Future.run(Unknown Source)
    68.     at com.sun.glass.ui.win.WinApplication._runLoop(Native Method)
    69.     at com.sun.glass.ui.win.WinApplication.lambda$null$148(Unknown Source)
    70.     at java.lang.Thread.run(Unknown Source)
    71. Caused by: java.io.IOException: Access is denied
    72.     at java.io.WinNTFileSystem.createFileExclusively(Native Method)
    73.     at java.io.File.createNewFile(Unknown Source)
    74.     at nul.IIIIIIiiiiII.new(zmb:81)
    75.     at nul.iIiiiiiIiiii.do(xe:191)
    76.     at nul.iIiiiiiIiiii.do(xe:105)
    77.     at nul.iIiiiiiIiiii.do(xe:223)
    78.     at nul.IiIIiIiIIIIi.<init>(zub:196)
    79.     at nul.iIIiIIiIiiII.do(qsb:12282)
    80.     at java.lang.Iterable.forEach(Unknown Source)
    81.     at nul.iIIiIIiIiiII.new(qsb:13081)
    82.     at com.sun.javafx.application.PlatformImpl.lambda$null$173(Unknown Source)
    83.     ... 6 more
    84.  
    85. java.io.IOException: Access is denied
    86.     at java.io.WinNTFileSystem.createFileExclusively(Native Method)
    87.     at java.io.File.createNewFile(Unknown Source)
    88.     at nul.IIIIIIiiiiII.new(zmb:81)
    89.     at nul.iIiiiiiIiiii.do(xe:191)
    90.     at nul.iIiiiiiIiiii.do(xe:105)
    91.     at nul.iIiiiiiIiiii.do(xe:223)
    92.     at nul.iiIIiIiIiiiI.<init>(zwb:84)
    93.     at nul.IIIiiIiIIIIi.<init>(hrb:89)
    94.     at nul.IIIiiIiIIIIi.<init>(hrb:24)
    95.     at nul.iiIiiIiiIiII.<init>(htb:96)
    96.     at nul.iiIiiIiiiIII.<init>(htb:96)
    97.     at nul.iiIiiIiiiIII.<init>(htb:225)
    98.     at nul.iIIIiIiIiiiI.do(nqb:138)
    99.     at nul.iIiiIIiiiIII.do(qsb:19778)
    100.     at nul.iIiiIIiiiIII.call(qsb:4769)
    101.     at javafx.concurrent.Task$TaskCallable.call(Unknown Source)
    102.     at java.util.concurrent.FutureTask.run(Unknown Source)
    103.     at java.lang.Thread.run(Unknown Source)
    104.  
     
  2. @Cloud here's a better look at the issue some of the users are having.
     
  3. We're getting denied access to creating files in our temporary directory while storing a style sheet in it so that we have a url we can feed to the control.
    --- Double Post Merged, Apr 19, 2016, Original Post Date: Apr 19, 2016 ---
    And that directory is
    System.getProperty("user.home") + File.separatorChar + "RuneMate" + File.seperatorChar "temp"
     
  4. Should the client be denied access even with admin rights?
     
  5. It shouldn't be denied at all. That directory is fair game. Have you tried running as admin?
     
  6. He said he has but I don't know how admin rights would go when our exe fires off a jar afterwards which. I'm really not sure how java handles being given admin anyways.
     
  7. @deathizpro please close your client and post a screenshot of File Explorer open to this directory: C:\Users\{YOUR USERNAME}\RuneMate\temp\
     
  8. @Arbiter It's an empty directory, no hidden files/folders either. And yeah this whole time I've been trying to run as an admin (also tried without admin rights and that didn't do anything). I've tried running the install as an admin too but it runs into the same problem.
     
  9. Can you delete the temp folder entirely and try again? Also check to make sure that even without admin rights you can place files into it.
     
  10. Just tried. Without admin rights I can copy/paste things into it and create completely new folders/notepads in there as well. Tried the client after that and running into the same problem. I can leave the client running for a few hours and see if that'll load anything into it but so far that hasn't worked.

    Edit: @Cloud I could store in the temp folder manually but nothing worked in regards to the bot.
     
    #10 Serene, Apr 19, 2016
    Last edited: Apr 20, 2016
  11. Lol, unless I run my RM from Admin I get an IO error. But when I do, the majority of the bots just entertain me with broken interfaces and features.
     
  12. If the client loads, then the broken interfaces/features are a result of bot issues. Post on their specific threads.
     
  13. We made some slight changes to temporary files in a blind attempt to fix this, any changes with V2.0.4?
     
  14. Still no fix. Returns the same io.IOException, and this time I also encountered a NullPointer?
     
  15. uhm, post the NullPointerException please.
     
  16. I tried but the forum won't let me. It says "Sorry, you have been blocked." I can post the log if I take out the nullpointer so I'm guessing it's a specific block from the forum. 'll try to PM you or upload the log.

    EDIT:
    @Cloud won't let me upload the file or paste the code. Here's a screenshot.

    [​IMG]
     
    #16 Serene, Apr 20, 2016
    Last edited: Apr 21, 2016
  17. Can you please post it on pastebin or gist.github.com? I need to be able to copy and paste it because even if I mistyped one letter (or typed it with the wrong case), I would have to retype it all.
     
  18. @Cloud Seems like this is a no-fix situation. Any way i could manually go back to the RuneMate version I had before spectre?
     

Share This Page

Loading...