Question Runemate has run out of accessible memory, try allocating

Discussion in 'Client & Site Support' started by Thayl0, Sep 20, 2016.

  1. I tried the fix in sticked thread however it doesn't seem to have made a difference.
     
  2. Please post more information about your system.

    Operating System
    Java version
    Hardware information
    How many instances are you trying to run?
    What bots are you trying to run?

    Be more descriptive.
     
  3. Windows 10
    Latest
    i5 4670k 1070 gpu 16gb ram
    2
    Dawg Mining
     
  4. Highly recommended closing and re-opening Spectre between instances. Further to that, have you assigned the max you can to Spectre? (1300MB with your OS)
     
  5. Are you talking about each bot i run open up a separate runemate.

    Untitled.png
     
  6. Pretty sure that's meant to be:
    Restructure your 'Target' field so that -Xmx1300M is not wrapped in quotation marks.

    And no, I mean if you're running 1 instance, when you're done with that instance and want to change bot, or restart your bot after running it for a few hours, close Spectre, reopen it and start a new instance that way. This clears your memory of Spectre and reassigns it.
     
  7. Thanks, also I don't know if you can do anything but i bought support last night and I can't run 3 bots.
     
  8. Can you confirm this is still the case? There's an issue where if you close a session unexpectedly the servers don't realise the session has ended until ~20 minutes after.
     
  9. I can not comfirm as this memory issue is pretty bad and I can't hard run a bot without it happening,
     
  10. These are separate issues - just try to start the maximum number of instances you should be allowed and check that you're able to.
     
  11. I can comfirm it doesn't work. Says failed to bind game because of exception
     
  12. Ah, that's a different issue. Go to Help > Logs in Spectre and post the contents of the most recent log in spoiler tags.
     
  13. It appears I only get the error above when i try to attach the third client. If I load a third client i get a popup saying unable to create advertising
     
  14. That's a RuneScape issue - not a client issue. You can workaround by opening the RuneScape windows at the same time as fast as you can.
     

Share This Page

Loading...