Resolved Runescape client not being detected

Discussion in 'Client & Site Support' started by Matty20, Sep 5, 2016.

  1. Hi guys,

    I am having an issue with the Runescape client not being detected.
    It is correctly opening the Runescape Legacy client, but does nothing from there.
    I have googled, and followed all the instructions.

    Uninstalled anything to do with Runescape / RuneMate / java and reinstalled.
    I have even used Revo uninstaller to find any files that may not be being removed in the uninstall process.

    I made sure to install RuneMate first as it installs Java automatically then install the Legacy client.

    This works on my computer at home and I have also ran a VirtualPC running windows on this computer and it works on that too.

    For scripting I prefer to work from my work computer and my home computer. I would rather not use VirtualPC at work to script bot.

    As i'm running this on Windows 10, I thought it may be to do with Windows stupid UAC, so I have disabled it. (Not fully using the registry hack) I have also tried running RuneMate as administrator. As I was originally receiving an error with the registry.

    Sep 06, 2016 11:07:51 AM java.util.prefs.WindowsPreferences <init>
    WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
    The file selected as the local bot directory does not exist, attempting to create it now.​

    I have checked the logs and am not getting any errors.
    [Debug] RuneMate Version: 2.3.5
    [Debug] Java Version: 8u101 x64 (Oracle Corporation)
    [Debug] Operating System: Windows 10 x64
    Attempting to start official client. If it does not open shortly please do so manually.
    Checking for a new game instance every second for two minutes or until one is found.​

    It used to work before i formatted my hard drive.
    Is there anything else that I can do to get it working?

     
  2. Best Answer:
    Post #4 by Matty20, Sep 29, 2016
  3. Says right there: [Debug] Java Version: 8u101 x64 (Oracle Corporation)

    RuneMate requires a 32-bit JRE.
     
  4. To elaborate, RuneMate requires to be ran on a JRE that matches the Runescape client. The Windows Runescape Legacy client runs on it's own 32-bit JRE, so RuneMate will need to be ran on a 32-bit JRE, the native installer should take care of this.
    Although, the clients should still be able to be detected, attaching should fail if the JREs don't match, the fact that they're not detected is strange.

    Is your work computer set up differently than your home computer, in regards with user directories, install directories, or permissions?
     
  5. Hi slash, thanks for the reply.
    It is setup exactly the same as my home computer.

    I installed x64 java after it failed just in case that was the problem.
    Wasn't aware it required 32-bit but none the less I have both 32 and 64 installed now and am still experiencing the issue.
    I can run the Runescape legacy client and login and play, just RuneMate doesn't detect the process.

    Also I should note, I have granted full permission to RuneMate with no success.

    Also, just for proof, I uninstalled Java x86 and reinstalled manually.
    This is all I get still.

    [Debug] RuneMate Version: 2.3.5
    [Debug] Java Version: 8u92 x86 (Oracle Corporation)
    [Debug] Operating System: Windows 10 x64
    Attempting to start official client. If it does not open shortly please do so manually.
    Checking for a new game instance every second for two minutes or until one is found.​
    --- Double Post Merged, Sep 29, 2016, Original Post Date: Sep 6, 2016 ---
    Can someone please mark this as resolved.

    Windows ran an anniversary update which has somehow fixed my issue with the client not being detected.
     

Share This Page

Loading...