Bug Spectre not attaching to RS Unix client

Discussion in 'Client & Site Support' started by ricespud, Jun 26, 2016.

  1. I read Slash say to use Oracle JDK instead of OpenJDK so I removed it and installed the following:

    [email protected]:~$ java -version
    java version "1.8.0_92"
    Java(TM) SE Runtime Environment (build 1.8.0_92-b14)

    Log is attached. When I try to add an instance it just spins. Using Lubuntu 16.04 in VirtualBox with 4gb RAM.
     

    Attached Files:

  2. Run RuneMate using sudo.
     
  3. I will try this when I get home. I installed RuneMate with the installer so I've just been clicking on the icon. Can I run it with sudo sh?

    EDIT: Ok I've run it with sudo. Still just green circles spinning. Here's a screen shot of the terminal after doing so.
     

    Attached Files:

    #3 ricespud, Jun 27, 2016
    Last edited: Jun 27, 2016
  4. Use a real desktop environment. Unity, GNOME, etc. None of that XFCE crap.


    Sent from my iPhone using Tapatalk
     
  5. I'm attempting to install GNOME on top of xfce but I may just end up starting all over. Is there a distro you'd recommend? I'm doing all this in a VM so I'm using these premade osboxes.org VDIs which may be problematic.
    --- Double Post Merged, Jun 28, 2016, Original Post Date: Jun 28, 2016 ---
    I nuked the Lubuntu VM and started over with Linux Mint 17.3 Cinnamon. Running RM from terminal with sudo. It detects my client but when I click "start instance" it spins for a couple of seconds and goes back to client list.

    java -version
    java version "1.8.0_91"
    Java(TM) SE Runtime Environment (build 1.8.0_91-b14)
    Java HotSpot(TM) 64-Bit Server VM (build 25.91-b14, mixed mode)

    Found a new game instance after 24 seconds.
    Scanned for and identified 1 game frames in 1487ms.
    java.lang.NoClassDefFoundError: Could not initialize class sun.tools.attach.LinuxVirtualMachine
    at sun.tools.attach.LinuxAttachProvider.attachVirtualMachine(jr:58)
    at com.sun.tools.attach.VirtualMachine.attach(ry:2486)
    at nul.IiIIIIiiIIIi.byte(jsb:131)
    at nul.iiiIIIiIIIiI.run(asb:42)
     
  6. Use Oracle JDK, not OpenJDK.
     
  7. @Cloud are we missing something on our end or is he on the JRE end?
     
  8. Try the Oracle JRE, not the Oracle JDK. It may be colliding with our version of the Attach Provider.
     
  9. I noticed this while installing RuneMate on yet another VM.
    [​IMG]

    Does this shed any light on the situation? After removing OpenJDK with sudo apt-get update && apt-get remove openjdk* and installing Oracle JRE, I installed RM and got this. Note that when I try java -version I get java version "1.8.0_91" when it looks like RM downloaded 1.8.0_92. Thanks a lot for the help so far both of you, hopefully I'll be able to get this working.
     
  10. If the installer downloads its own JRE you should be absolutely fine. If this is not the case then please post an updated log of the error, including the startup debug specifying versions and such.
    --- Double Post Merged, Jul 2, 2016, Original Post Date: Jul 2, 2016 ---
    Additionally we do the most testing with Ubuntu 14.04 LTS. We officially also support Debian and CentOS, but testing on it is more limited.
     
  11. Okay I'm going to try that. So just to be clear I should be fine with ubuntu-14.04.4-desktop-amd64.iso from Ubuntu 14.04.4 LTS (Trusty Tahr) ? And do you have a recommended/supported version of Java for me to install? When I run RuneMate_setup.sh it appears to be installing java-1.7.0-openjdk-amd64, but I thought everyone is saying to use Oracle not OpenJDK. Thanks
    --- Double Post Merged, Jul 2, 2016, Original Post Date: Jul 2, 2016 ---
    Just installed Ubuntu 14.04.4. InstalledRM using RuneMate_setup.sh and installed Java using:
    sudo apt-add-repository ppa:webupd8team/java
    sudo apt-get update
    sudo apt-get install oracle-java8-installer

    [email protected]:~$ java -version
    java version "1.8.0_91"
    Java(TM) SE Runtime Environment (build 1.8.0_91-b14)
    Java HotSpot(TM) 64-Bit Server VM (build 25.91-b14, mixed mode)

    [email protected]:~$ sudo RuneMate
    [sudo] password for ricespud:
    [Debug] RuneMate Version: 2.2.7
    [Debug] Java Version: 8u92 x64 (Oracle Corporation)
    [Debug] Operating System: Linux x64
    Downloading 3 missing or outdated cloud resources.
    Scanned for and identified 1 game frames in 14160ms.
    Scanned for and identified 1 game frames in 10968ms.
    java.lang.UnsatisfiedLinkError: no attach in java.library.path
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1867)
    at java.lang.Runtime.loadLibrary0(Runtime.java:870)
    at java.lang.System.loadLibrary(System.java:1122)
    at sun.tools.attach.LinuxVirtualMachine.<clinit>(xs:710)
    at sun.tools.attach.LinuxAttachProvider.attachVirtualMachine(qy:44)
    at com.sun.tools.attach.VirtualMachine.attach(kz:11042)
    at nul.IiiIiIiIIIii.byte(gjb:224)
    at nul.IIIiIIiiIiIi.run(slb:34)

    javafx.fxml.LoadException:
    /root/RuneMate/temp/813964722.res

    at javafx.fxml.FXMLLoader.constructLoadException(FXMLLoader.java:2601)
    at javafx.fxml.FXMLLoader.loadImpl(FXMLLoader.java:2579)
    at javafx.fxml.FXMLLoader.loadImpl(FXMLLoader.java:2441)
    at javafx.fxml.FXMLLoader.load(FXMLLoader.java:2409)
    at nul.iiiiiiiiiIii.byte(xh:156)
    at nul.iiiiiiiiiIii.byte(xh:209)
    at nul.IIiiIIiIIIII.<init>(kwa:81)
    at nul.IiiIIIiiiIii.byte(kra:20318)
    at nul.iIiIiIiIIIii.byte(zsa:22)
    at nul.IiiIiIiiIIIi.byte(mqa:1046)
    at nul.IiiIiIiiIIIi.call(mqa:2269)
    at javafx.concurrent.Task$TaskCallable.call(Task.java:1423)
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    at java.lang.Thread.run(Thread.java:745)
    Caused by: MediaException: UNKNOWN : com.sun.media.jfxmedia.MediaException: Could not create player! : com.sun.media.jfxmedia.MediaException: Could not create player!
    at javafx.scene.media.MediaException.exceptionToMediaException(MediaException.java:146)
    at javafx.scene.media.MediaPlayer.init(MediaPlayer.java:511)
    at javafx.scene.media.MediaPlayer.<init>(MediaPlayer.java:414)
    at nul.IIiiIIiIIIII.initialize(kwa:152)
    at javafx.fxml.FXMLLoader.loadImpl(FXMLLoader.java:2548)
    ... 12 more
    Caused by: com.sun.media.jfxmedia.MediaException: Could not create player!
    at com.sun.media.jfxmediaimpl.NativeMediaManager.getPlayer(NativeMediaManager.java:274)
    at com.sun.media.jfxmedia.MediaManager.getPlayer(MediaManager.java:118)
    at javafx.scene.media.MediaPlayer.init(MediaPlayer.java:467)
    ... 15 more
    --- Double Post Merged, Jul 23, 2016 ---
    Hate to necro my own thread but I just wanted this to be marked as resolved. It would appear the problem was something to do with VirtualBox or the fact that I was running Linux in a virtual machine. I got my hands on a spare physical machine and loaded Linux Mint 17.3 on it and in 5 minutes I was up and running with RM attaching to the Unix client. Thanks for all the help.
     

Share This Page

Loading...