Personally, I think functions like Camera.passivelyTurnTo should be called Camera.promiseTurnTo or Camera.concurrentlyTurnTo. To me, passive sounds like stoic: you tell it to turn, and it will turn and not give a shit. Instead, the function returns a promise (hence the name) and you can cancel the function while it's executing, great! So that's why I'm creating a poll for the deprecation of the old function names, and addition of new function names. Of course this would be for all functions that are currently called passive.