Bug Troubles setting up on Linux vps

Discussion in 'Client & Site Support' started by Devphreak, May 15, 2016.

  1. So I've downloaded the rsu client from github.com and removed all java versions so that the one runemate installs will be used. When I run runescape I can login play and everything. But when I open runemate it seems to work fine until I want to start a bot, it does indicate that there is a running client of runescape but when trying to create a bot instance it just does nothing. That is, I select my account the script bot and the client and press the start button which indicates it's pressed but nothing happens and the ui freezes. This is on Ubuntu 16 and 14 as well as kubuntu 14. Can anyone help me set this shit up properly?

    Sorry for the shitty layout and all, I don't own a pc atm so I'll have to manage everything with my phone.
     
  2. What DE are you using?
     
  3. Xfce and on kubuntu the one that comes pre-installed. Do I need unity or something?
     
  4. I'm running xfce and arch on my laptop, and it's working fine.
    Could you check your log for any errors? It should be in your RuneMate folder located in your home directory.
     
  5. Will post it in a min, this is what it looks like.

    [​IMG]
    This is using unity desktop with the rsu client. I also had these issues with the client downloaded from Runescapes official ppa
    Logs: http://pastebin.com/raw/vbWy6pT1
    Found a new game instance after 67 seconds.
    java.lang.UnsatisfiedLinkError: no attach in java.library.path
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1867)
    at java.lang.Runtime.loadLibrary0(Runtime.java:870)
    at java.lang.System.loadLibrary(System.java:1122)
    at sun.tools.attach.LinuxVirtualMachine.<clinit>(po:16181)
    at sun.tools.attach.LinuxAttachProvider.attachVirtualMachine(oi:95)
    at com.sun.tools.attach.VirtualMachine.attach(fn:170)
    at nul.IiiIIIiIIiii.enum(cbc:274)
    at nul.iIIiiIiiiiiI.run(udc:74
     
    #5 Devphreak, May 15, 2016
    Last edited: May 15, 2016
  6. @Vaped no attach :/

    @Devphreak try installing a 64bit jdk and using that.
     
  7. Tried using that already, oracles jdk using their ppa. Didn't work either :/

    Edit:
    Gonna replace the jre that comes with rm with the jdk. I'll update if it works.

    Edit 2: Didn't work either. It can't locate rs3 game cache this time.
    --- Double Post Merged, May 15, 2016, Original Post Date: May 15, 2016 ---
    @Arbiter @SlashnHax

    I tried setting it up on Arch Linux and now it doesn't even seem to open Runemate nor rsu client...
    Pretty sure I'm doing something wrong. Isn't there a how to for Linux?
     
  8. Provide us with the latest log and find out where the jagexcache folder is on your computer.
     
  9. @Arbiter
    Www.Pastebin.com/YdWub8p1
    This is all I there was in the logfile.

    [Debug] RuneMate Version: 2.1.5
    [Debug] Java Version: 8u91 x64 (Oracle Corporation)
    [Debug] Operating System: Linux x64
    Scanned for and identified 0 game frames in 2553ms.
    Scanned for and identified 1 game frames in 3423ms.
    Scanned for and identified 1 game frames in 1387ms.
    Scanned for and identified 1 game frames in 1324ms.
    Failed to locate an existing game cache for RuneScape 3.
    Gamecache is located at: ~/Desktop/rsu-client-master/runescape/share/cache
    It contains: jagexappletviewer.preferences
    Jagex_cl_runescape_LIVE.dat
    Random.dat
    Jagexcache > Runescape > LIVE > preferences1>3.dat
    Mainfilecache.idx0 > 49 + 255
    All I could find, hope it's sufficient.

    Edit: I'm running the standalone version here.
     
    #9 Devphreak, May 15, 2016
    Last edited: May 15, 2016
  10. Yeah that's a very unusually location for it. It's likely because you're running from source instead of installing one of their releases. Is that the case? If so, install a release properly.
     
  11. My bad, indeed I cloned the project as I didn't know there existed an installer. Will update if it works.

    It works now =) Thanks
     
    #11 Devphreak, May 16, 2016
    Last edited: May 16, 2016

Share This Page

Loading...