Bug Bug Limit on 2 Bot instances

Discussion in 'Client & Site Support' started by Synonym, Jul 24, 2016.

  1. I've been having a problem probably 30 minutes ago this shows up. "Looks like you've reached your limit of 2 bot instances". Get this in mind I have no bot operating at that moment.


    Solutions I have tried:

    Restarting RM.
    Restating PC.
    Restarting my Internet.

    Please help.
    --- Double Post Merged, Jul 24, 2016, Original Post Date: Jul 24, 2016 ---
    Ok, I tried all of this and still it didn't work. Then a couple minutes after i Posted this it worked again. Weird.
     
  2. I'm assuming you're force closing RuneMate or otherwise ungracefully closing it. When you do this it doesn't tell the server that the instances are ending, and it takes some time for the session to expire on its own.
     
  3. Stop spamming bots, wait 30 minutes, try again
     
  4. Hmm. I see It was unresponsive so i forcibly closed it. That must have been the case, but I didn't spam it though.

    But there are times that it is unresponsive but didn't have this kind of error. First time to encounter it.
     
  5. Just started with coding my own project. Because i am pretty new to the bot scene i need to debug often and a lot. I quit 2 times via stop process inside IntelliJ(red square). Now i am also getting this error.

    source: Resolved - runemate reached bot instance limit

    A nice solution would be a force expire session button or smth, atleast in developer mode.
     
  6. Keep in mind the answer to your issue is posted in the sticky thread:

    Runemate says you have reached your instance limit & you can't load another instance:
    If the client is force-closed (or crashes), it can take the RuneMate servers up to 30 minutes to identify that the session has ended. Please wait up to 30 minutes and try again. If you still cannot run another instance, let us know. Supporters can run more instances than free users, see: Upgrade | RuneMate
     
  7. Or you could just close Spectre normally without ending the process :p

    If you're using the normal Run mode, not Debug with Hotswapping, you should be able to recompile your bots, and then refresh your bot list and you should be able to test your latest changes.
     
    placebo likes this.

Share This Page

Loading...